5
$\begingroup$

I seem to have a problem that I cant find the solution for any where...

The problem I'm having is that when I export my UV Map and import into my editing program whether that be paint or paint.net I zoom in to the UV Island boundaries and I can see some blurriness and transparency; somewhat like it has some antialiasing. It would make my life easier if I could simply use the magic wand tool to select the right area for each face/island.

I've played with some of the settings in blenders UV tab in the UV editor and I cant seem to find anything that is fixing the problem with the exported texture. I apologize if I don't seem to make any sense, its hard to explain the problem im having and there are no solutions online from what I could find.

Image of what it looks like in blender: Image of what it looks like in blender

Image of what it looks like once exported into paint.net: Image of what it looks like once exported into paint.net

Thankyou in advance!

$\endgroup$
1
  • 1
    $\begingroup$ Welcome to the Blender Stack Exchange community, @RyanEarnshaw. It's standard procedure, here, to edit - cut -the images so that only the relevant parts appear. $\endgroup$ – someonewithpc Feb 5 '15 at 19:11
5
$\begingroup$

PNG will be anti-alliased.

Try to export your UV map as .SVG. It will be anti aliased too but you can change this. export UV

I'm using gimp (it's free). I don't know if you can do that in paint.net

Open your .SVG in gimp. Choose the size and check "Import Paths" and "merge imported Paths" (tried to translate).

import svg in gimp

in the "Paths" tab, click on "paint along path"

paint path

uncheck "antialiasing", choose your line width (color will be foreground color)

parameters

your lines will be exactly the color you want, nothing more, nothing less.

final

$\endgroup$
2
  • $\begingroup$ cheers man, this worked! $\endgroup$ – Ryan Earnshaw Feb 8 '15 at 14:30
  • $\begingroup$ glad to help :) be aware that diagonals won't be antialiased. $\endgroup$ – Bithur Feb 8 '15 at 14:43
2
$\begingroup$

That's caused to the low resolution of the image the UV map is mapped to; this resolution is the same that the file containing the UV layout will have when you export it.

To increase the resolution, press either the New or the + button, next to the name of the texture, depending on wether you already have another texture opened; then, a dialog box will appear, in which you can set the resolution of the texture slot - 1024 squared is the default, so use something like 4096 by 4096. You can change the Generate Type from Blank to UV Grid, and then press Ok.

enter image description here

$\endgroup$
2
  • $\begingroup$ followed your steps and it didnt fix my problem. I still get the blur around each island unfortunately. $\endgroup$ – Ryan Earnshaw Feb 5 '15 at 19:54
  • $\begingroup$ @RyanEarnshaw That's basically inevitable; all you can do is make it higher resolution $\endgroup$ – someonewithpc Feb 5 '15 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.