0
$\begingroup$

How do I make my textures or colors display in blenders game engine? My textures in blender will not appear in bge when I run my game and it ends up looking like this:

This is an bge (blender game engine) image of my game that has a problem of loading my textures.

I added some textures and colors to my objects in blender render but when I go into blenders game engine and run the game it looks black and white (image shows above shows no textures that I have added). I have multitexture enabled in my scene.

Any way of fixing this?

$\endgroup$
  • $\begingroup$ This is way too simple, and the question is not specific. Try to use GLSL texturing, but I am not sure because you didn't provide any info. $\endgroup$ – blackhole Jun 12 '14 at 3:44
  • $\begingroup$ I edited my question with a bit more of details. $\endgroup$ – Blender Warrior Jun 12 '14 at 3:56
  • $\begingroup$ Where do I enable GLSL texturing? $\endgroup$ – Blender Warrior Jun 12 '14 at 3:59
  • $\begingroup$ With the render engine selector set to 'Blender Game', you can set the shading mode to GLSL from the Scene tab of the properties editor. $\endgroup$ – Mike Pan Jun 12 '14 at 8:32
  • $\begingroup$ Okay I can now see all my textures and stuff. Thank you. That should just be an answer. $\endgroup$ – Blender Warrior Jun 12 '14 at 14:24
2
$\begingroup$

I figured the problem out.

  1. Go to Materials for any of your objects in blender game engine
  2. Select an image or any kind of texture you like
  3. In game engine scroll down until you see bake drop down menu. Click the Bake drop down menu and leave everything as is unless you know what you are doing. I left my bake mode as full render and then I click bake button. You may or may not get an error but the error for some reason is wrong and your textures do end up getting baked so this must be a bake problem.
  4. Then click Standalone player drop down menu and click star and boom you now see your textures!

Image of my game and texture below:

Blender Game Engine; Playing my blender game.

I haven't finished my texture for my game yet but this how I got my textures to appear finally. I wonder why when you press p you don't see any of your textures but as a standalone game you can, just odd :/.

$\endgroup$
  • $\begingroup$ This is how I solved my problem and hope this may solve others problems. $\endgroup$ – Blender Warrior Jun 18 '14 at 23:28
  • 1
    $\begingroup$ when you press P for embedded playing, you will play with the current view options. You can play it in wireframe if you want. Choose Textured to see them. $\endgroup$ – brita_ Jun 20 '14 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.