0
$\begingroup$

So i made a very simple fluid simulation in blender 2.91.2 and whatever I try nothing happens (or at least shows up). The only time I get anything to work if I use a cube as domain and a UV sphere as source and don't change any settings, if I do change settings it stops working.

(I've professionally worked with Maya fluids and FumeFX in 3DS Max and never was unable to do something this simple... so it really does my head in.)

I put the file in my drive: https://drive.google.com/file/d/1XDHwj7VaQmdBpcKmjyYpgrdfTt5CUYry/view?usp=sharing

and the folder which also has some screen capture of what's happening https://drive.google.com/drive/folders/1WjghxtmzMD7vKJR1b1Ic5yOotuOmIFVy?usp=sharing

enter image description here

$\endgroup$
1
  • $\begingroup$ So someone told me the domain must be a cube, no rectangle and now it works. I edited the shape of the cube to optimize the amount of voxels used, but apparently blender doesn't like that. Weird since any other voxel based sim i can think of lets you do that. maybe something i'm missing? or maybe something blender is missing. $\endgroup$ Jul 7, 2021 at 15:16

1 Answer 1

1
$\begingroup$

If i were you i would first watch some beginner tutorials about Mantaflow.

You made many mistakes and i know it sounds hard but your are missing basic understanding about mantaflow.

Just to tell you a few:

  • you cannot have multiple domains (you can ...but it is pretty complicated. If you add more than one - as beginner - you will always have problems)

  • obviously you don't know what inflow and what outflow is. Inflow means: water runs out of the object in the domain. So water will be added to the domain. Outflow means: water runs in the object and will be subtracted from the domain. You just added outflows so there is no water at all flowing in your domain.

  • in Blender there is something called "face orientation". This must be right so that the water simulation works right. Normally the face orientation should be in that way, that the faces are shown "blue" if you check the "show face orientation" checkbox

  • if you have effector objects - their geometry must be "closed". You let them "open". By that i mean e.g. a cube is closed with 6 faces, if one face is missing, it is "kind of" open.

$\endgroup$
2
  • $\begingroup$ Thanks for the answer! So the only thing i could find is that not every source was on inflow. deleted all but one domain I checked everything so my source is on inflow. I checked face orientation and double checked it with normal orientation I checked that my effector has no holes anywhere and all vertices are welded together... Still nothing :/ (also blender doesn't update every time i click a different object. 60% of the time when I click an domain object it still shows the physics properties of the previous object, so I have to click it again and again until it updates. weird) $\endgroup$ Jul 7, 2021 at 14:58
  • $\begingroup$ Did you upload your updated file? $\endgroup$
    – Chris
    Jul 7, 2021 at 15:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .