0
$\begingroup$

I am a beginner, so I'm just learning how to make fluid simulations in blender. I have a fluid simulation with a domain, 3 effectors, and the inflow, which has 2 keyframes, one at the start and one at the end. The keyframes are for the use infow checkbox, the first one with use inflow on, and the second with use inflow off. I moved the inflow off keyframe from 40 to another place (I forget, somewhere between 40 - 60 exclusive), and then to frame 60. But, when I play the simulation, at frame 47, it stops and restarts (goes back to where there was only a little fluid in the scene). It also restarted at frame 53. Help! I am using blender 2.82a, and Windows.

Blend file: https://drive.google.com/file/d/1mlmLsOfclxOvEghPIv5HvV3vIm8Scqf1/view?usp=sharing

$\endgroup$
  • $\begingroup$ why your effectors are "turned off"? $\endgroup$ – Sanbaldo May 31 at 19:52
1
$\begingroup$

I see from your file that you are not using the cache. Switch to modular type (under DOMAIN > physics properties > cache) and every time you change something, clear the cache and recalculate it (using the CACHE button under domain > settings).

try this and share your feedback

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Do you mean the bake data button? Because I don't see a cache button under the settings. $\endgroup$ – CrazyVideoGamez Jun 1 at 11:44
  • $\begingroup$ check the screenshot $\endgroup$ – Sanbaldo Jun 1 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.