1
$\begingroup$

I imported a tank model from a game, extracted with Ninja Ripper. The model has some smoothing issues while even if I tried select the mesh and soft all verts, faces and edges in shading panel, the mesh still looks weird.

Also tried the auto smooth option. I'm not quite sure the faces are in this look due to only smoothing or also the flips or something inverted. With ⌃ Ctrl + N I did found some of the faces on the turret turns different while some are not.

enter image description here

I don't know if it has something to do with flipped normals so I recalculated the normal with ⌃ Ctrl + N or ⌃ Ctrl + ⇧ Shift + N and this is the output:

enter image description here

$\endgroup$
4
  • 1
    $\begingroup$ In Object Data > Geometry Data, try Clear Custom Split Normals Data $\endgroup$
    – moonboots
    Jan 9 at 21:09
  • $\begingroup$ Thx! But I checked the geometry data and the only one option can be used is Add Custom Split Normals Data. $\endgroup$
    – Seraphim
    Jan 10 at 18:36
  • $\begingroup$ so maybe share your file or at least a part of it? pasteall.org/blend $\endgroup$
    – moonboots
    Jan 10 at 18:38
  • $\begingroup$ Thanks a lot! The file is here: pasteall.org/blend/dfa2cd18c9074d2791cfc060efe47df2 $\endgroup$
    – Seraphim
    Jan 10 at 20:11
0
$\begingroup$

You need to do 3 things to get a clean shading:

  • You have sharp edges, so, in Edit mode, CtrlE > Clear Sharp
  • You have overlapping vertices, so, Edit mode, select all and (in 2.79) W > Remove Doubles
  • As I said, in the Properties panel > Object Data > Geometry > Clear Custom Split Normals Data
$\endgroup$
5
  • $\begingroup$ thank you so much! However ummm there's only a Add Custom Split Normals Data on my end in the panel. imgur.com/a4tUzEh $\endgroup$
    – Seraphim
    Jan 11 at 1:12
  • $\begingroup$ that's weird because I had the Clear button and I had to use it... $\endgroup$
    – moonboots
    Jan 11 at 5:24
  • $\begingroup$ Can you help me to fix that? I tried reload a raw file but still Blender did not provide that option to me. Is it possible for you to fix and then send the the file in .obj to me? Thanks! $\endgroup$
    – Seraphim
    Jan 11 at 5:50
  • $\begingroup$ sure, here it is, tell me if it works: pasteall.org/blend/529e1517ccc34bb7aadfe3b3b859bdd8 $\endgroup$
    – moonboots
    Jan 11 at 5:52
  • $\begingroup$ Thank you so much! It is perfect! You saved my day! $\endgroup$
    – Seraphim
    Jan 11 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.