enter image description here

I’ve been watching “Blender Guru” make a donut and following. I first made my texture paint fine, but when I did the displacement something went wrong. I don’t remember why, it just turned black.

I went to redo my texture paint and now it’s just black. No matter what I do, my paint won’t show and it is only black.

Also, this might help more. I did change the blend in texture painting and I could paint on it. But it was the cloud texture. I tried to change it, but now I can’t paint anything on it.

  • 1
    $\begingroup$ Do you have a light in the scene? $\endgroup$ Commented Oct 8, 2020 at 23:12
  • $\begingroup$ I do have a light $\endgroup$
    – Ben S
    Commented Oct 8, 2020 at 23:43
  • 2
    $\begingroup$ Share some screenshots of your setting or even share your Blend File $\endgroup$
    – Emir
    Commented Oct 9, 2020 at 2:21

2 Answers 2


I had the same problem too, but I fixed it by following the instructions to this answer. Here are the steps:

1. In the Texture Paint tab, press N, and click Tool on the right side-bar.

2. Under Brushes click the X button to delete the brush, then add a new brush.

3. Then select a colour under Brush Settings, go to the Colour Picker dropdown, and then draw over the object.

I hope this works for you.


I got it to work. I did this by starting over from a few steps back. There was a mask texture on it, and I deleted it. Then it worked


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .