0
$\begingroup$

I realise so many people have asked this question so many times, but I just can't see what I'm doing wrong here.

I'm on Blender 2.83.2. I have a simple scene with a room and some objects, some with glossy shaders. There are 3 point lights on the ceiling providing plenty of direct and indirect light, so shadows are soft and mostly diffused, and in most cases there are very few shadows due to the generous slather of light being dumped into the shot from 6 point lights on the ceiling.

This is a portion of the shot rendered in Cycles without denoising for reference: Grainy much

And this is the full frame with denoising creating what you expect... a shot that looks like someone smeared my camera lens with a potato. Looks like a potato

These are my cycles settings, which are set to default except for indirect clamp being set to 10 as part of my own troubleshooting. I've tried samples up to 512, and there was virtually no difference from the results I got with 256 samples. So I suspect I'm doing something else to create this noise beyond just being stingy with compute power:

enter image description here .

I used to think Cycles only struggled when lighting was low, so I was surprised when I first switched from Eevee to see how it would look.

Any help is greatly appreciated. Thanks.

$\endgroup$
3
  • 1
    $\begingroup$ Hello :). Since Blender 2.81 there's a new denoiser that should give better results. But 512 samples is rather low. $\endgroup$ – Jachym Michal Jul 28 '20 at 13:13
  • 1
    $\begingroup$ Related: Which denoiser is better? $\endgroup$ – Jachym Michal Jul 28 '20 at 13:13
  • $\begingroup$ To fix this: turn off the denoiser, up the samples to at least 300 and use intels denoiser in the compositor. $\endgroup$ – brockmann Jul 28 '20 at 17:49
0
$\begingroup$

Denoising works well only at high resolutions, in my experience from 4k. Try putting more samples, or increasing the resolution and using denoising. I rendered a scene with different light sources on 512 samples. In addition, you can see examples of different samples and noise effect here Will increasing samples reduce fireflies? enter image description here

1000:1000px; 128 samples and denoising. enter image description here

1500:1500px; 256 samples and desoising on compositing tab. As far as I know, sometimes denoising in the compositing tab, for some reason, works differently than in setting the view layers :)

$\endgroup$
7
  • $\begingroup$ That's the odd thing here, the renders above were with 256 samples, but doubling to 512 samples looked identically bad... so the old addage of "add more samples" doesn't seem to apply for some reason. I just tried changing my lighting out for a surface emission plane and noticed the noise drastically reduced at even 128 samples! So it must be something to do with using point lights. $\endgroup$ – irwazr Jul 28 '20 at 12:43
  • $\begingroup$ what resolution do you render? do you have the opportunity to send your project? $\endgroup$ – John Ber Jul 28 '20 at 12:46
  • $\begingroup$ I'm rendering is 1920x1050. $\endgroup$ – irwazr Jul 28 '20 at 12:52
  • $\begingroup$ Try doubling this and use denoising. Denoising works in fact like smart blur, so the higher your resolution, the better it will work. I added examples at the top. $\endgroup$ – John Ber Jul 28 '20 at 12:58
  • $\begingroup$ That's a lot of unnecessary overhead. Try the intels denoiser in the compositor and you'll save a lot of time... blender.stackexchange.com/questions/173760/… $\endgroup$ – brockmann Jul 28 '20 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.