2
$\begingroup$

Lately I have this problem with my renders when after rendering I get weird light effects (fiereflies) especially on walls that are just plain coloured. Like in this render

enter image description here

( It's closed room with 5 area lights from ceiling and one from lamp) I get this effect, especially around and at objects that are "ceramic". I tried different things that have worked in different projects, but with this one seems like nothing works (render was made and denoised with 2000 samples).

Here is 2000 samples without denoising

enter image description here

Thank you for any advice!

$\endgroup$
  • 2
    $\begingroup$ This looks like result of denoise.. Though rendered at 2000 samples really shouldn't be that much noisy. It could clarify things if you post a screenshot of render without denoise. Also look into Clamp Direct in the rendering settings $\endgroup$ – Mr Zak May 19 '19 at 12:16
  • $\begingroup$ imgur.com/oepH0VB here is 2000 samples without denoising $\endgroup$ – magimi May 19 '19 at 13:13
  • $\begingroup$ I made the area lights bigger and It helped a little bit but still I have these "dirty" spots in some places. The Clamp Direct method I rather not use cause it messes up with photorealism $\endgroup$ – magimi May 19 '19 at 13:23
  • $\begingroup$ Clamp Direct was meant to be turned off. It is clear now that those are caused by denoise. I'd say this is huge amount of noise for 2000 samples. Share more details about the scene please, like is it closed room or not, how objects and lamps are set up, what kind of lamps are there, provide some screenshots of scene layout. See some tips blender.stackexchange.com/questions/18304/… and blender.stackexchange.com/questions/4980/… $\endgroup$ – Mr Zak May 19 '19 at 13:42
  • $\begingroup$ Avoid using the denoiser. To get rid of the fireflies use clamp "indirect". see: blender.stackexchange.com/questions/40040/… $\endgroup$ – user1853 May 19 '19 at 15:30
0
$\begingroup$

These "splotches" are because of Blender's default denoiser. They can be removed by increasing the denoising radius (something like 14 px or so). However, it has other serious side effects (eg, incorrectly blurring the sharp shadows of things like individual leaves of a plant). Try using Intel's Open Image Denoiser in compositor, or Nvidia Optix denoiser (https://www.youtube.com/watch?v=eGAjsSNtX6E) instead. They're relatively better denoisers.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.