1
$\begingroup$

enter image description hereAfter putting way too many hours into this scene, I'm finally ready to render. The problem is I get a ton of noise, no matter how many samples I choose, and denoising just makes the image look like garbage. I've searched and searched and searched for a good solution, but I can't seem to get it right. The image attached was rendered with 512 samples without denoising and took about 45 minutes. Please somebody help! Also, if someone has a better way to set up a glass shader with lettering on it that will allow light to pass through the glass and not the lettering (see the signage on the desk for example, the lettering should cast a shadow), I would be greatly appreciative!

[EDIT]: Added an updated render and a screenshot of my settings [EDIT2]: I'm only seeing the updated render, but none of my other pictures are showing up for me. I hope you all can see them.

$\endgroup$
  • $\begingroup$ Can the glass hack here help you? youtu.be/KyXRBu7gn2o?t=315. $\endgroup$ – lemon Jul 11 at 15:39
  • $\begingroup$ I'll give it a shot, thanks! I used this video to make the current shader plus my own messing around to get the lettering to show up properly (minus the shadows of course): youtu.be/1p7l9MNpLdo $\endgroup$ – BlumpkinKing87 Jul 11 at 15:58
0
$\begingroup$

I increased my render output resolution to 4K and got rid of about half the amount of light sources and nearly all the noise disappeared! Also, I managed to solve my glass shader issue with a few extra hours playing with the shader editor and came up with a great solution for casting the shadows I was looking for. I've attached a screenshot of the shader node tree, I hope someone else can make some use of it as well.enter image description hereenter image description here

$\endgroup$
-1
$\begingroup$

Try decreasing the light bounces in the render settings. Anything above 3 or 4 looks very similar. Also try turning off reflective and refractive caustics (may affect your final result.) Both of these options are found under the "Light paths" section of the render settings tab.

$\endgroup$
  • $\begingroup$ Reflective and refractive caustics were both already turned off unfortunately, but I did lower my light bounces down to 2 across the board. I think diffuse was set to 8, but the highest otherwise was 4. I also changed my exposure from -2 back to 0 and I'm currently pumping out a fresh render. Update coming soon! $\endgroup$ – BlumpkinKing87 Jul 12 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.