1
$\begingroup$

The problem: Blender does not start and prints the following error message:

Error! Unsupported graphics card or driver. 
A graphics card and driver with 
support for OpenGL 3.3 or higher is required.

Background: Blender should run on a virtual linux system started from a terminal with a X Server. The system gets the graphic card (NVIDIA Tesla P100 Card) by passthrough with OpenGL 4.6.

How to force blender to use this graphic card? Is there a config file, where the graphic card could be explicit set before the start of blender? Or is there some configuration of the X Server or the virtual system neccessary?

Usage: I want to use blender for rendering images of 3D models.

$\endgroup$
5
  • $\begingroup$ Could you define 'use'? Blender will use the card a monitor is connected to for drawing its UI, but you can set a different card for rendering in most cases. Sometimes it is glitchy- for example I use GTX970 but I cannot run Blender on integrated Intel HD 530 graphics with GTX970 enabled as well because of bugs while both cards work fine separately. So sometimes there are issues with using one for UI and another for rendering, but with other card combinations it works fine. $\endgroup$ – Martynas Žiemys Jul 22 '20 at 13:54
  • $\begingroup$ Please edit your question and add information on what kind of GPU you are using. By default the drivers for nvidia cards will not use CUDA, so you need to use the proprietary drivers, not the opensource ("nouveau") driver. $\endgroup$ – susu Jul 22 '20 at 16:57
  • $\begingroup$ The use is running blender. My main problem is during trying to start blender I get the following error message: ALSA lib confmisc.c:767:(parse_card) cannot find card '0' ... Error! Unsupported graphics card or driver. A graphics card and driver with support for OpenGL 3.3 or higher is required. But I have on the computer a NVIDIA Tesla P100 Card with OpenGL 4.6. $\endgroup$ – user101746 Jul 23 '20 at 7:11
  • $\begingroup$ community.khronos.org/t/… $\endgroup$ – user101746 Jul 23 '20 at 13:20
  • $\begingroup$ No, it is propably cause by an indirect rendering setting for the graphic card driver similar as mention under link. The warning ALSA lib confmisc.c:767:(parse_card) cannot find card '0' is propably caused by a missing sound device, but can suppressed by ./blender -noaudio. $\endgroup$ – user101746 Jul 23 '20 at 13:28
1
$\begingroup$

Could it be, that the issue is caused, because blender required some sound card?

No, it is probably cause by an indirect rendering setting for the graphic card driver similar as mentioned here. The warning ALSA lib confmisc.c:767:(parse_card) cannot find card '0' is probably caused by a missing sound device, but can suppressed by ./blender -noaudio.

$\endgroup$
4
  • $\begingroup$ community.khronos.org/t/… $\endgroup$ – user101746 Jul 23 '20 at 13:20
  • $\begingroup$ Welcome to the site :) I've taken the liberty of editing your question and answer with information from your comments to make it easier for others with the same problem to find what they're looking for. If you disagree with any of my edits, please feel free to make additional edits and/or rollback my changes. $\endgroup$ – gandalf3 Jul 24 '20 at 21:42
  • $\begingroup$ That said, is it possible you're looking to run blender on a headless system (no display)? If so, the --background option might be of interest. $\endgroup$ – gandalf3 Jul 24 '20 at 21:43
  • $\begingroup$ Gandalf3, thank you very much for your support. $\endgroup$ – user101746 Jul 28 '20 at 10:10
0
$\begingroup$

Blender was displaying the same error message to me. My problem was that in addition to the video ports provided by my AMD RX 580 graphics card which supports OpenGL 4.6, the motherboard also provided an HDMI video port that did not support OpenGL 3.3. However, my monitor was plugged into the less capable port. Switching the monitor cable to the port on the graphics card solved the issue.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.