0
$\begingroup$

i can't open Blender 2.80 since it tells me that it requires OpenGL 3.3 to run.
Well, when i start it with my intel graphics adapter everything is fine, but it fails, if i want to start it via optirun / primusrun with my nvidia graphics card, although it supports OpenGL 3.3.

Output:

Read prefs: /home/daniel/.config/blender/2.80/config/userpref.blend
AL lib: (EE) GetLoadedHrtf: Invalid header in /usr/share/openal/hrtf/default-44100.mhr: "MinPHR02"
AL lib: (EE) GetLoadedHrtf: Failed to load /usr/share/openal/hrtf/default-44100.mhr
AL lib: (EE) GetLoadedHrtf: Invalid header in /usr/share/openal/hrtf/default-48000.mhr: "MinPHR02"
AL lib: (EE) GetLoadedHrtf: Failed to load /usr/share/openal/hrtf/default-48000.mhr
Error! Blender requires OpenGL 3.3 to run. Try updating your drivers.

Here are some (maybe usefull) outputs:

1.) glxinfo | grep OpenGL

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.2.2
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.2.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.2.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

2.) optirun glxinfo | grep OpenGL

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 840M/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 410.57
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 410.57
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:

3.) mhwd -l -d --------------------------------------------------------------------------------

PCI Device: /devices/pci0000:00/0000:00:1c.4/0000:03:00.0 (0302:10de:1341) Display controller nVidia Corporation GM108M [GeForce 840M] -------------------------------------------------------------------------------- INSTALLED:

NAME:   video-hybrid-intel-nvidia-bumblebee
ATTACHED:   PCI
VERSION:    2018.08.09
INFO:   Hybrid bumblebee solution for NVIDIA Optimus Technology - Closed source NVIDIA driver & open source intel driver.
PRIORITY:   8
FREEDRIVER: false
DEPENDS:    -
CONFLICTS:  video-intel video-nvidia video-nvidia-304xx video-nvidia-340xx video-nvidia-390xx video-hybrid-intel-nvidia-390xx-bumblebee video-hybrid-intel-nouveau-bumblebee 
CLASSIDS:   0300 0302 0300 
VENDORIDS:  10de 8086 

> AVAILABLE:
...

If i try to force the version to 3.3 (for whatever reason) with MESA_GL_VERSION_OVERRIDE=3.3 and MESA_GLSL_VERSION_OVERRIDE=330 it still outputs version 4.6.

A bit weird is that i was able to run blender some weeks ago, but changed some stuff in my linux configs which shouldn't have anything to do with my hardware / drivers / etc. The only difference is that i was using gnome on wayland and now i'm using i3 on Xorg.

Suggestion to fix it are welcome.
Daniel

$\endgroup$
  • $\begingroup$ Did you install a new Blender 2.8 version? If not, the issues might come from a Linux modification (drivers, desktop environment, linux kernel, etc.). You said you used Gnome and switched to Xorg ; you should try to login using Gnome to check if Blender works. $\endgroup$ – Yann Masoch Oct 15 '18 at 23:23
  • $\begingroup$ Yes, i tried the newest version, but also the older one, which still worked some weeks ago (it's just the zip-Version). Now, when i switch back to Gnome (with wayland), it shows the same error. So it doesn't look like the problem depends on the desktop environment or display server... As far as i can remember, the drivers or the linux kernel hasn't been updated since then. $\endgroup$ – dkirchhof Oct 16 '18 at 21:53
  • $\begingroup$ That's not easy to figure out. But now we know that the issue is not coming from Gnome or Xorg or so. Also, your GeForce 840M supports OpenGL 4.5 (Nvidia website) and your Nvidia driver is recent, but your OpenGL version is still 3.0. The issue is probably coming from another thing such as OpenAL: Invalid header in /usr/share/openal/hrtf/default-44100.mhr $\endgroup$ – Yann Masoch Oct 16 '18 at 22:53
  • $\begingroup$ This will also come up, if i start blender without optirun... Now i tried to reinstall my drivers, but without success :( $\endgroup$ – dkirchhof Oct 17 '18 at 18:45
  • $\begingroup$ I saw on Google that people had the same issue with OpenGL 2.1 because of their old graphic card or because of their graphic driver. You should try to update your driver through Ubuntu and also to uninstall/purge totally the Nvidia package and to reinstall the driver using the .run file you can download on Nvidia website. Keep me posted and good luck! $\endgroup$ – Yann Masoch Oct 17 '18 at 23:23
1
$\begingroup$

The issue is not openGL, but OpenAL (deals with sound rendering). Looks like hrtf function is enabled and can't be loaded. Disabling it in openAL configuration file alsoft.ini might help (hrtf=false). It is probably at /usr/share/, but you can look at source https://github.com/kcat/openal-soft/blob/master/alsoftrc.sample for details

$\endgroup$
  • $\begingroup$ The OpenAL error occurs also when i start blender 2.79, but it doesn't matter (in my case), blender 2.79 works. $\endgroup$ – dkirchhof Oct 28 '18 at 21:34
0
$\begingroup$

You on Manjaro too?

sudo pacman -S virtualgl lib32-virtualgl lib32-primus primus
sudo systemctl enable bumblebeed

and rebooting fixed optirun for me, primusrun is broken still. https://forum.manjaro.org/t/nvidia-bumblebee-problem/62936/10

$\endgroup$
  • $\begingroup$ Yes, i'm running manjaro as well. I don't have the problem anymore (see my own answer). I can run blender with optirun and with primusrun. primus and lib32-primus are installed - virtualgl and lib32-virtualgl aren't. $\endgroup$ – dkirchhof Oct 28 '18 at 22:00
0
$\begingroup$

For some other reasons, i installed a complete fresh linux system (manjaro i3) on my notebook, a few days ago. After installing blender, there was the same error again - a wrong detected opengl version.
Today, i installed some updates. A little while ago, i recognized a new notifaction on stackexchange and tried to start blender again. Et voila, it starts.
Well, it could be the update, it could be a dependency of steam, which i installed after the update, it could be anything... Not really a solution, but the problem has gone.

$\endgroup$
0
$\begingroup$

So, I had failed repeatedly trying to resolve the issue of Blender not launching anymore due to a failure of interacting with openGL.

I thought of reinstalling graphics drivers so that openGL would be reorganised and maybe it would work. Since my GPU is nvidia, I thought to install nvidia-driver. This ruined everything and my system became locked in a reboot. Basically, I had kinda bricked my computer as it kept on FAILING to load Kernel modules. I learned that graphics driver can mess up kernel module loading - GUI things and all.

DO NOT INSTALL NVIDIA DRIVER IF YOUR LINUX PC ISN'T LAUNCHING OPENGL.

So, once I figured out how to launch terminal in recovery mode I was on to resolving the issue because it only made sense to undo what was done to cause the kernel crash in the first place. In this case, I needed to remove everything nvidia, and then try running an update or dist-upgrade. I chose dist-upgrade because an upgrade was due and available already. Problem got solved.

In summary: I had blender already installed and working fine until I wanted to install an epub reader. OpenGL got corrupted and Blender refused to launch after the last exit. I updated openGL via mesa. It didn't work. Installed Nvidia and my computer crashed. I removed nvidia components and my system was restored and Blender is now working fine.

So, if you ever get this error message from trying to launch Blender, or any app for that matter: *"Read prefs: /root/.config/blender/2.79/config/userpref.blend /build/blender-X0i0N1/blender-2.79.b+dfsg0/intern/ghost/intern/GHOST_WindowX11.cpp:198: X11 glXQueryVersion() failed, verify working openGL system! initial window could not find the GLX extension Writing: /tmp/blender.crash.txt Segmentation fault"* Then remove nvidia and delete the xorg.conf file and reboot:

In terminal:

sudo apt remove --purge nvidia*  #the asterisk * like in other programs indicates all
sudo apt autoremove
rm -rf /etc/X11/xorg.conf #the xorg configuration file. In this case, nvidia had corrupted that file, which affected the launch of Blender
reboot

*To launch linux in terminal mode, press Ctrl+Alt+F3 or Ctrl+Alt+F2

Somehow, I can't help thinking that the whole matter could have been resolved by the rm -rf option. :(

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.