1
$\begingroup$

I've been trying to make my render camera match the viewport global camera, but I can't find the proper settings. It seems that the viewport camera is different from the standard render camera though they have the same Focal Length (50mm). Moreover, there's no viewport camera's size option.

Viewport camera:

enter image description here

Render camera:

enter image description here

Viewport camera shows more extreme angle and does not distort the image. Render camera looks more like orthographic.

How can I configure my render camera to match the viewport camera (to get the same render result)?

Thank you for reading my post!

$\endgroup$
5
  • $\begingroup$ Check that the clip start and end on the camera is the same as the one for the viewport $\endgroup$
    – susu
    Jul 15 '20 at 3:34
  • $\begingroup$ Thank you for your comment! I wish it was this option that could solve the issue! The viewport camera has only Focal Length parameter, while a standard camera has Size option. I think it is what is different. As you tweak this parameter things get better, but still different from the viewport camera. $\endgroup$
    – Artem
    Jul 16 '20 at 1:37
  • $\begingroup$ It is hard to help if we know nothing about your project, but you can help others help you if you edit your post and add more images of your settings. There is only so much others can do without your assistance $\endgroup$
    – susu
    Jul 16 '20 at 2:23
  • $\begingroup$ Well, it's just all by default) Default render camera's parameters are: Focal Length: 50mm, Size: 36. Sensor Fit: Auto. $\endgroup$
    – Artem
    Jul 17 '20 at 22:59
  • $\begingroup$ If you really want an answer (as it seems you do) you need to share more information or the blend file. Instead of writing comments edit the original question and show pictures of the camera settings. $\endgroup$
    – susu
    Jul 17 '20 at 23:09
1
$\begingroup$

Your camera settings might be off, make sure to in the sidebar under view that you are using the same camera in the view properties and the scene properties. Images to help you find where they are. enter image description here

enter image description here

Make sure that the local camera (One you want to use for preview in viewport) has the same name as the one in the scene properties.

$\endgroup$
4
  • $\begingroup$ Thank you for your advice! Unfortunately, it does not solve the issue. I would like my standard render camera to be the same like the viewport camera, but not vise versa. It seems like there's something about Focal Length and Size settings. Tweaking them helps a bit, but the geometry gets distorted in a close distance for the render camera though it doesn't for the viewport camera. I just use the standard settings. $\endgroup$
    – Artem
    Jul 14 '20 at 5:21
  • $\begingroup$ It's possible you have set the perspective modes to be different in the camera settings. Does that fix it? $\endgroup$ Jul 14 '20 at 7:10
  • $\begingroup$ No, it's all set by default. I think I should look to something about viewport camera settings and compare them to the standard render camera. $\endgroup$
    – Artem
    Jul 14 '20 at 8:52
  • $\begingroup$ I had a similar but different issue and I'm pretty sure it was because I had scaled the camera. Even after comparing ALL settings between a 'good' project my 'problem' project, I could find NO diffs - I deleted and recreated the camera and my issue was resolved. I suspect I could not see the source of the problem because I had applied all transformations to my camera. Not sure if this is helpful but I think it cause some pain for me. My new camera works much better, so perhaps you could give that a try. $\endgroup$
    – Jon
    Jan 22 at 12:03
1
$\begingroup$

I know this is a very old post, but I came across this because I was also having the same issue and nothing here was helping either - it turns out I was just being stupid and had forgot I had used this scene to create an animation and I'd set the camera and/or object to be animated on the first frame.

Once I'd gone and created a new key frame for frame 1 and removed the rest, everything was fine again.

Hope this might help someone else realize they were doing the same thing :)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.