2
$\begingroup$

I need to make this blue vectors appears blue inside this orange material.

In other words, how I can "preserve" material color from color interferences of another objects?

I'm using cycles render.

Thank you very much. enter image description here

I made the steps proposed and achieved this result:

enter image description here

$\endgroup$
1
  • $\begingroup$ give it an Emission node instead of a DIffuse? $\endgroup$
    – moonboots
    May 13 '20 at 5:56
3
$\begingroup$

Edit:

My bad, your cube is actually opaque, which was hard to guess from the pictures, I don't know if it's feasible with the Light Path node (?) so, as Thedigitalzorn said, the solution is probably to use the Compositor.

Another simple trick would be to launch a render of the arrow only, in the Properties panel > Render > Film, enable Transparent to make sure that the video has a transparent background. Then render the cube and the setup. At last, stack the 2 sequences in the Video Sequencer.

Old answer:

Give your arrow an Emission node instead of a Diffuse. And if you don't want it to emit any light, deactivate its Diffuse option in the Properties panel > Object > Visibility.

enter image description here enter image description here

$\endgroup$
8
  • $\begingroup$ Thank you. But it's works because this cube is not color, correct? I followed this same steps and the result is different. $\endgroup$
    – Info2010
    May 13 '20 at 15:36
  • 1
    $\begingroup$ in what way is it different? $\endgroup$
    – moonboots
    May 13 '20 at 15:40
  • 1
    $\begingroup$ hard to understand what happes, do you mean you want the object to always be seen through any object? $\endgroup$
    – moonboots
    May 13 '20 at 15:56
  • 1
    $\begingroup$ still hard to understand, could you please make a larger screenshot or share your file? blend-exchange.giantcowfilms.com $\endgroup$
    – moonboots
    May 13 '20 at 16:12
  • 1
    $\begingroup$ it was hard to understand that your box was actually half opaque, so it's normal that any object inside will appear colored... like thedigitalzorn says, I think you'll have to fix that through the Compositor editor, I don't know enough about it though $\endgroup$
    – moonboots
    May 13 '20 at 17:35
0
$\begingroup$

If the arrow has a solid color, you could use a cryptomatte to isolate the silhouette and give it a color using the compositing nodes.

$\endgroup$
1
  • $\begingroup$ Thank you for your answer. I didn't find cryptomatte in node editor. I'm using blender 2.8. $\endgroup$
    – Info2010
    May 13 '20 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.