0
$\begingroup$

Here are some pictures of my settings and result: enter image description here enter image description here

On the right side of this image is the EXR file imported normally, and on the left side is a PNG without transparency. That's the look I want to get from the EXR file.

enter image description here

It is a different Image but has the same settings.

I have used the method described in this GitHub(https://github.com/sobotka/filmic-resolve) but my results are looking a bit janky.

And I have exported the multilayer EXR with Float Full. I don't know if that could be the problem.

This is my previous post from where I have the GitHub link: EXR color difference to PNG

$\endgroup$
8
  • $\begingroup$ I’d be interested in the broken shitty job that myself and other folks have collaborated on. Can you provide some samples? I’ll try to get some eyes on it to see what the issue is. Resolve really is unfit for scene referred work in many respects, and as such, there are pitfalls all over the place. All examples appreciated. $\endgroup$
    – troy_s
    Apr 11 '20 at 19:33
  • $\begingroup$ Ah I should note, you need to start from Filmic Log Encoding Base files. EXRs are a much more challenging thing to solve, and the results are extremely sub-optimal with the Resolve free edition. $\endgroup$
    – troy_s
    Apr 11 '20 at 19:37
  • $\begingroup$ Here is the Blend and Davinci FIle: drive.google.com/drive/folders/… $\endgroup$
    – Phönix 64
    Apr 11 '20 at 20:26
  • 2
    $\begingroup$ Go to the project settings, set the CM to Davinci Resolve CM, set all to linear (input, timeline and output). Load your EXR sequence to the timeline, swtich to the Fusion tab, add an OCIO colorspace node, load Filmic All-Views OCIO config and set the input to "Linear" and the output to the contrast variant you had in Blender. Remember to turn-out the grid icon in the viewer (the view LUT). Go back to the timeline or jump to the colour page, the preview should match Blender display. I can post this as an answer with screenshots if necessary. $\endgroup$
    – Gez
    Apr 11 '20 at 21:47
  • 1
    $\begingroup$ github.com/sobotka/filmic-blender/tree/all-views $\endgroup$
    – Gez
    Apr 11 '20 at 21:49
6
$\begingroup$

Question:

How to match an EXR (linear scene-referred information) to a PNG (in display referred values with sRGB "gamma" curves) of the same image in resolve?

The issue:

Even though both images are generated from the same render layer in blender, they are going through different pipelines and the values don't match: The PNG is encoded with a gamma curve (sRGB, 2.2) and the information has been scaled to fit within the 0-1 values of display referred, while the EXR is still in Scene-Referred values that exceed what the display is capable of representing on the screen. All values past 1 are displayed as "clipped" or "pure white".

A graphic to illustrate. Both images loaded in blender:

enter image description here

On the vectorscope you can see how the image brightess values for each channel are represented. The bottom of the scale is 0 (black) and the top 1 (or 100%, meaning white).

The image on the left is the EXR. Notice how values over 1 are ignored and "hard clipped". There is a flat line at the very top. All values higher than one or 100% are ignored.

If sampled, some of the values in this EXR exceed a value of 24 on the red channel, way over what the display can deal with.

On the right of the image is the PNG, the vectorscope shows how the highlights are scaled down to a displayable values (thanks to the color transforms called "filmic"). Note how they curve at the top, and some (in the green and blue channel) don't reach 100 percent, giving the flame a "yellowish" tone.

Bringing the files to resolve shows the same difference.

The EXR file:

enter image description here

The PNG one:

enter image description here

One solution:

To match the images, as cleverly pointed out by @Gez, both images would need to undergo the same color transforms.

Open fusion tab, load the EXR file and add a Ocio Color Space node, load the OCIO config file (config.ocio) from your blender folder and set the Source Space to Linear and output to Filmic Log Encoding. Since the Looks don't work in Resolve you have to add them manually using another node.

enter image description here

Add an OCIO File Transform node and look for the necessary LUT in the Looks sub-folder of the color management folder in Blender (in this example the lut is Filmic_to_0-60_1-04.spi1d for Medium Low Contrast). Set the direction to forward and the interpolation to linear.

enter image description here

The resulting image should be what you are looking for (on the left the PNG, on the Right, the EXR processed through OCIO nodes).

enter image description here

Note that Resolve is particularly tricky, using confusing (and sometimes wrong) terms, and has many settings that need to be correct for solution to work: The EXR file should use the correct color space (in this case sRGB) and it has to be interpreted as LINEAR ("Gamma space":None), "Remove Curve" should be checked.

enter image description here

On the media tab, the Alpha channel on the EXR has to be set to "premultipy".

Here's the final image and scope readings:

enter image description here


Other Solution.

Install the filmic LUTs from "Filmic Resolve ( https://github.com/sobotka/filmic-resolve) on your system.

Set the Input and Timeline color spaces for the project to Rec709(Scene) but do not set any lookup tables.

Import the EXR normally and do not assign any LUTs or other pre-processing to it in the media section.

On the color section use two nodes to get the filmic look:

The first node uses a LUT-3D LUT-Filmic-Filmic Resolve-Scene Linear to Base Encoding.

The second node uses a LUT-3D LUT-Filmif-Filmic Resolve-Medium Low Contrast.

enter image description here

$\endgroup$
9
  • $\begingroup$ @troy_s , and Gez I suspect the alpha has to be pre-divided and post multiplied at the end of the chain. Yes? $\endgroup$
    – susu
    Apr 12 '20 at 18:59
  • $\begingroup$ Thank you I will try it out $\endgroup$
    – Phönix 64
    Apr 12 '20 at 22:26
  • $\begingroup$ And do you now why GIMP crashes when I try to open a multilayer EXR file with it? Error message ( it is in german sorry): imgur.com/a/0Put1kX it basically says that the EXR plugin has crashed. $\endgroup$
    – Phönix 64
    Apr 12 '20 at 22:42
  • $\begingroup$ GIMP is a piece of software I avoid, no can help you, sorry. Krita will import EXRs correctly. $\endgroup$
    – susu
    Apr 12 '20 at 22:47
  • $\begingroup$ It worked. Okay I just installed Krita and I will yous that for EXR files thank you. $\endgroup$
    – Phönix 64
    Apr 12 '20 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.