0
$\begingroup$

I have a render I've made of a model in blender and it has a transparent background, I've saved it as a PNG (which should keep the transparency) and imported it into the video editor. Once its imported it has a black background and the only way to change the transparency seems to be the opacity, but I don't want the whole image to be transparent. I've tried changing the film settings to allow for transparency but that hasn't made a noticeable difference.

Blender image render saved as a PNG.

Blender video editor imported image, the blacked out region should be transparent, like in the previous image.

How can I get the transparent parts of my image to be transparent again?

edit:

$\endgroup$
8
  • 1
    $\begingroup$ Would you mind showing the whole program window so that we can see at least a few settings? $\endgroup$ Feb 13 at 12:28
  • $\begingroup$ Its currently at the default settings for the video editor when its selected from the blender launch window. The only things Ive changed is properties > render > film >transparency on. $\endgroup$
    – sleepy
    Feb 13 at 12:31
  • 1
    $\begingroup$ The Film > Transparent makes the scene background transparent for scene rendering, it has nothing to do with rendering image strips in the Video Sequence Editor. Please show the whole editor window, especially the Preview window and the Output Properties for the video file. Or upload your scene here: blend-exchange.com (best with the image sequence packed inside the file) and follow the instructions there to edit it into your question so we can examine the file ourselves. $\endgroup$ Feb 13 at 12:43
  • 2
    $\begingroup$ The Video Sequence Editor settings look okay. The first image shows the Render Result with transparency... have you checked the rendered files if they actually have transparency? Because the transparency shown in the Render Result is how it was rendered, not how it was saved. If you have saved the PNGs for example as Color > RGB instead of RGBA, the transparent background will be black because you saved the image without alpha transparency. $\endgroup$ Feb 13 at 13:16
  • 1
    $\begingroup$ By the way, if you are not going to overlay this sequence inside Blender on some background showing through the transparent parts, rendering it like this as a video will get you a black background as well, because the default encoding settings are saving a video file that does not support transparency (see the missing RGBA in the output properties). Only the Video Codec "QT rle / QT Animation" and one or two others support transparency. $\endgroup$ Feb 13 at 13:25

1 Answer 1

0
$\begingroup$

Have you enabled the Use Alpha option under the Image or Movie strip properties in the Video Editor? This should preserve the transparency of your PNG image during the import process.

$\endgroup$
1
  • $\begingroup$ The previous commenter already helped me fix the issue, my png didn't have an alpha channel to read $\endgroup$
    – sleepy
    Feb 28 at 15:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .