0
$\begingroup$

I've been following this tutorial (using blender 2.8). At around 14:15 a sphere is created and a texture with some modifiers wrapped onto it; this is what I get when following the tutorial exactly:

With Eevee:

enter image description here

With Cycles:

enter image description here

Why does Cycles forget about the nodes?

I created the shader with "All" as the output.

Tried redoing the material directly in Cycles; now the sphere is purple by default and remains so even after the texture has been added.

$\endgroup$
  • 1
    $\begingroup$ Looks like something went wrong when switching the render engines, since the second screenshot still shows Eevee's properties in the Material Properties and the render pause button is missing the 3D View. Are there any error messages on the Console (Windows > Toggle System Console)? $\endgroup$ – Robert Gützkow Mar 19 at 21:28
  • $\begingroup$ I'm redoing the objects; I couldn't seem to be able to refresh the engine (I recreated the second object's material from scratch with the output set to Cycles but once created it remained purple). Pretty damn frustrating. $\endgroup$ – Sebi Mar 19 at 21:41
1
$\begingroup$

I was able to recreate the problem: it seems to be caused by setting material output to Cycles (in the material editor) while rendering with Eevee (in the render settings). The only solution I know is to render with the same render engine as you specify in the material.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I tried this but it seems to be stuck to purple while in Cycles; the first object renders fine in Eevee. Tried recreating everything using Cycles; it fails from the start. $\endgroup$ – Sebi Mar 19 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.