0
$\begingroup$

I've made an animation for my unity game. The problem is that every-time I export it the exported animation is imprecise at the feet of my character.

I already tried to set the "Simplify" in the export settings to 0, but nothing changed. I also tried to disable "All Actions" and "NLA Strips", and applied the scale on the armature and the mesh.

Here are my export settings: enter image description here

A quick video for better explanation here: https://youtu.be/2veA3o-hGUA

I don't know the problem and this issue is killing my game because its visible at some points :c.

$\endgroup$
0
$\begingroup$

I've encountered this issue myself, I'm not sure if it's Blender or the FBX format, there are things you can do to help mitigate the problem by adjusting the "Sampling Rate" value or "Simplify" value, there are also settings in Unity that may help as well try changing the Keyframe Compression to "Optimal" or "Off" in the Inspector tab. Other than this I haven't found any other solutions myself.

| improve this answer | |
$\endgroup$
0
$\begingroup$

I found this has helped me

1) For your model's Animator component, be sure Apply Root Motion is checked:

2) In the Animator window, click the little gear icon and then be sure IK Pass is checked ("IK" should appear left of the gear when this is enabled. enter image description here

3) Click on the Idle animation in the Animator window and be sure Foot IK is checked. enter image description here

4) Click on the Motion value in the property sheet to go to the animation itself. Check Bake Into Pose and select Original for each of Root Transform Rotation, Root Transform Position (Y), and Root Transform Position (XZ).

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.