1
$\begingroup$

I have a mesh, a plane, and it is supposed to be a landscape with grass. It has some ups and downs not a flat plane. When adding the hair(grass). I did some weight paint to tell where the grass should grow. It seems to be more grass on lower parts of the mesh for some reason. The strange thing is that it looks fine in the viewport but not after rendering in Eevee. I have played around with the settings but can't find any solution. Would appreciate any help here.

Image1

Image1

$\endgroup$
0
$\begingroup$

Sometimes reloading/reopening your blender file helps to force eevee to use the recalculated particles. It might be using a cached version.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Unfortunately not. It is llike it is calculating the growing from center not the surface but I can't find any settings for it. $\endgroup$ – Peter Jan 7 at 19:32
  • $\begingroup$ Are the particles (a) where you don't want them weight paint wise, or (b) are they not conforming to the ground properly (growing in mid air)? If it's 'a' then make sure there's 0 weight in the vertex group where you've painted/erased the weight fully blue, as in select the group in edit mode and make sure there are no verts. in the group where you don't want grass. If it's 'b'- is the ground displaced (modifier) and if so is the displace mod. above the particle mod. in the stack, and if that's OK have you chosen 'use modifier stack' in the particle settings emission/source drop-down? $\endgroup$ – MarkS Jan 8 at 10:13
0
$\begingroup$

This was all due to an unforgivable mistake of me. It is so embarrassing I can't even say what it was that caused this. Everything is working just fine. But as a remember to other: Never forget to disable a plane in render as well as in viewport if you don't use it. Maybe I should delete this whole post.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Another user may find the information useful if they happen across the same problem at some point. It is always much more useful for future users of the site to write your complete solution than not to. $\endgroup$ – Timaroberts Jan 8 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.