2
$\begingroup$

I have a mesh and added hair particles to it with some settings. The hair are growing inside the mesh. I have weight paint the mesh so that it grow outside the mesh only. Still the hairs are inside and outside. I added the vertex group below in density. May i know the reason why the hairs are inside.

enter image description here

$\endgroup$
2
$\begingroup$

There are two ways to handle hair particles: Using the settings in the Particle tab and using the Particle Edit mode. The Particle Edit mode can take the particles created by the Particles tab as a starting point and alter them freely using the brushes. Most settings can still be controlled by the sliders in the tab, however the roots and the direction of the hair are overwritten by the Particle Edit mode.

You have two Particle Systems on your object: one is a mess and the other one is working fine. In your first Particle System the hair is inside the object because it was combed this way using Particle Edit mode.

If you reset these changes by clicking Free Edit, you can see that the hair is only on the outside. enter image description here enter image description here

To solve this issue, you should be more careful when combing the hair using brushes. Some settings like Deflect emitter or Keep Root are very useful to keep the hair on the outer surface without penetration when using the comb brush.
enter image description here

$\endgroup$
2
$\begingroup$

Problems come from two issues: rotation not applied and mesh with Ngons. To solve some of them you can:

  • free particle edit of your "small hair2"
  • select the mesh and apply rotation and scale (Ctrl+A )
  • recomb your hairs

To solve all issues, do a quick retopology to have a "quads only" and "edge loops only" mesh, and exclude from the vertex group all vertices that belong to the internal, borders also (think in terms of which faces you want to emit hair).

Another workaround could be make a copy of the external part of the mesh, delete the Ngons and extrude the last circle loop to reach the position of the previous borders, assign the particle systems to the new mesh and uncheck the "emitter" option in the particle render tab, so that the new mesh will not be rendered.

$\endgroup$
  • $\begingroup$ I tried above 3 steps but did not get success. Can you plz make it clear in detail with image or gif. $\endgroup$ – atek Sep 22 '17 at 13:12
0
$\begingroup$

I ran into this issue with a fairly complex cat model, where no matter what I did, i had bald spots right on the cat's eye socket:

Even with a lower particle count in preview, it's clear there's no hair around the eye. :(

What finally achieved the result i wanted was adding a second particle system that did not emit child particles. This way I had total control over where they were pointing and how dense they were:

Hooray!

Render Preview - you can clearly see the hair around the eye now!

It's also worth reiterating how important a good clean mesh is to making the hair go where you want. This is only my second 'large' 3D modeling project, so my topology is pretty terrible after posing, tweaking, and making a giant mess of things with a multiresolution modifier. :)

$\endgroup$
0
$\begingroup$

Try flipping normals of the mesh. This is most likely to occur while using solidify modifier.

$\endgroup$
  • 1
    $\begingroup$ Would be useful if you suggested how the user should flip the normals. $\endgroup$ – Ray Mairlot Jul 7 '18 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.