2
$\begingroup$

I'm using Blender 2.79 to render an animation. While many frames look consistent, every three or four frames, a series of frames crop up where a surface is rendered differently than the rest, often with what appears to be a depth of field blur in a different place. See the differences frame by frame with the ground surface here:

enter image description here

enter image description here

enter image description here

enter image description here

The first image is correct and the rest not correct.

I'm using a camera with a cube as a depth of field focus object, if that matters. Also using denoising, which doesn't seem to be the issue, and the fracture modifier for destruction. There is only one light in the scene that does not move.

Any hope for making the frames more consistent?

$\endgroup$
  • $\begingroup$ I'm not sure what you mean by "crop up". Do you mean that a specific glass shard isn't in focus as it's supposed to? Do you have the depth of field focus object at a static location or is it animated as well? $\endgroup$ – rjg Jul 19 at 21:17
  • $\begingroup$ The depth of field focus object is static. The glass shards appear as expected; it's the floor that isn't consistent frame to frame. It's as if parts of the floor are flickering in and out of focus. See the difference in the rendering of the floor from frame to frame above. $\endgroup$ – xcelspreadsheet Jul 22 at 13:59
  • $\begingroup$ I see what you mean. What is that catching the reflection on the floor in the first render a texture or simulated water? $\endgroup$ – rjg Jul 22 at 14:24
  • $\begingroup$ The floor has a texture fed into the Normal of an Anisotropic BSDF as well as the material's displacement. That's what the "scratched" effect is on the floor. Is that what you're referring to? $\endgroup$ – xcelspreadsheet Jul 22 at 14:43
  • $\begingroup$ Yes. Unfortunately I'm not sure what's causing this. Do you have caustics enabled? Does it make a difference when it's disabled? $\endgroup$ – rjg Jul 22 at 15:10
0
$\begingroup$

Whatever the issue was, it was resolved by re-rendering the whole project with a version of Blender 2.8 with Fracture Modifier (rather than 2.79b). Thanks to rjg for the suggestion!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.