0
$\begingroup$

I'm very new to Blender so sorry if this is quite obvious. I've been using Darrin Lile's character modelling tutorials on YouTube. It was all fine up until texturing. To briefly explain what the issue is, when using the 'Texture Paint' mode in Blender (the one that allows you to paint directly onto the object), the paint is appearing on the opposite side of some parts. For example, if I add paint onto the stomach, it will appear on the character's back.

I'm hoping the solution is something very simple but it's possible I've messed something up with the UV maps. However, my UV map seemed fine.

If anyone could help with this that would be great. Thanks for reading!

Here's the download link to my model:

$\endgroup$
  • 1
    $\begingroup$ do you mean it also appears on another part? It would mean that some parts of your UVmap are overlapping $\endgroup$ – moonboots Jul 2 at 15:38
  • 1
    $\begingroup$ Can you check in edit mode that your mesh face normals are all pointed outward? This is a common problem where texture paint is on the 'wrong side' of the mesh at times due to the normals needing to be corrected. $\endgroup$ – Craig D Jones Jul 2 at 15:42
  • $\begingroup$ Hi @moonboots, thanks for the answer. I can confirm that occasionally the paint appears on multiple parts. I think I can recall the tutorial I was using suggesting a way to move the UV islands around so I'll see what I can do and get back to you on that. $\endgroup$ – Jamie00 Jul 2 at 16:05
  • $\begingroup$ for a direct painting on texture, when you unwrap, use the Smart UV Project option, it will create islands that won't overlap by default, then paint on the 3D view (or UV/Image Editor) $\endgroup$ – moonboots Jul 2 at 16:07
  • $\begingroup$ Hi @CraigDJones, thanks for the answer. Sorry, I'm not really too sure what you mean exactly by that. If you mean, is the paint appearing on the inside of the model aswell, then yes it is. $\endgroup$ – Jamie00 Jul 2 at 16:07
1
$\begingroup$

It's a Normal issue: Go in Edit mode, select all, and press ctrlN to recalculate the normals (shiftN in 2.8).

$\endgroup$
  • 1
    $\begingroup$ ok I correct my answer $\endgroup$ – moonboots Jul 2 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.