0
$\begingroup$

I am very new to blender so apologies if there's an obvious solution I haven't tried yet.

The two images I have attached are of my current project: attempting to turn my minecraft skin into a 3D model. I was using this tutorial (which is 3 years old and outdated but I've been using google to find how to do the things) https://www.youtube.com/watch?v=3VYWQgRvhQ4

The texture of my model is perfect in texture paint mode. Exactly how it should be. It's messed up in every other mode though for some reason and I'm unable to figure out why. I've even looked at the texture itself and it's fine, I'm not sure why it's not displaying properly in almost every mode.

Please help.

The model and texture in texture paint mode

What the texture looks like in every other mode.

EDIT:

Here's the blender file of my project.

$\endgroup$
5
  • $\begingroup$ You might want to consider sharing your .blend file. You could share it here: blend-exchange.giantcowfilms.com It could help people figure out what's going on. $\endgroup$ Jul 19 '20 at 12:24
  • $\begingroup$ Just did! Thanks for the advice, hoping this helps us figure out what's wrong $\endgroup$
    – AppleChild
    Jul 20 '20 at 2:42
  • $\begingroup$ you might need to share the .blend file again with the textures packed into the file since the .blend file you provided doesn't have the textures included. To pack the textures into the file click on file then go to extrernal data and click pack all into .blend file $\endgroup$
    – Motcho
    Jul 20 '20 at 3:01
  • $\begingroup$ Ah, yes, my apologies. I should have mentioned that. $\endgroup$ Jul 20 '20 at 3:34
  • $\begingroup$ Actually I think there is no need to re-upload. : ) Go to the Settings in the Material Properties tab of you material and. Under Settings you should set both Blend Mode and Shadow Mode to Opaque. This should fix you problem. $\endgroup$ Jul 20 '20 at 3:44
1
$\begingroup$

Fjoersteller's comment:

Actually I think there is no need to re-upload. : ) Go to the Settings in the Material Properties tab of you material and. Under Settings you should set both Blend Mode and Shadow Mode to Opaque. This should fix you problem.

Thanks Fjoersteller, that actually fixed it! I had Blend Mode on Alpha Blend, but turning it to Opaque fixed the texture completely!!!

$\endgroup$
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.