1
$\begingroup$

I am trying to create a flow of water by duplicating metaballs along a curve. I've gone through the motions of creating a curve and a metaball, setting the Parent of the metaball to the curve, set the Duplication to Frames, unchecking Speed, and animated the End frame. Looks good in the viewport (sometimes needing to click the Update buttons to get it to update).

However, when I go into Rendered view or actually rendering the thing, none of the metaballs show up, not even the starting metaball. Changing Duplication to None shows the whole thing in Rendered View, but when I do anything to update the metaballs I only get the starting metaball. I even played around with the metaball's resolutions to no effect.

Is there any other method to create this growing "sausage"? Remember the material is semi-transparent so using ordinary spheres will produce ugly overlaps.

$\endgroup$
  • $\begingroup$ Simple plane with array modifier along curve and dupliface option can be used instead of your current setup. As for sphere overlaps - this can be eliminated inside shader, forcing all transparent bounces greater than 1 to be fully transparent (downside of this method is having a big number for transparency max bounds to reduce black artifacts). $\endgroup$ – Serge L Nov 1 '18 at 12:28
  • $\begingroup$ @SergeL I'm not getting the desired result, or I'm just misinterpreting that first part. Maybe make a full answer (tutorial) what you mean? $\endgroup$ – Edward Nov 1 '18 at 14:17
0
$\begingroup$

I don't know whether it's a bug or not, but if you ALT+D duplicate metaball on the same layer, dupliframed metaballs start rendering fine. To hide this copied metaball, clear relation to parent object (ALT+P) and put it outside view area or parent to camera and move behind it.

$\endgroup$
  • $\begingroup$ Very odd. Your blend file seems to work, but when I try the steps you suggested, it did not work. $\endgroup$ – Edward Nov 1 '18 at 16:18
  • $\begingroup$ Maybe share your file? $\endgroup$ – Serge L Nov 1 '18 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.