0
$\begingroup$

I have set up a fairly simple scene and have gone through the process of making and animating a sapling. I left it as a curve and applied a material to it. When I hit render, the tree doesn't show at all.

enter image description here

Note that the 'tree' object is NOT the tree I want rendered. That's why it is unviewable and urenderable

Note that the 'tree' object is NOT the tree I want rendered. That's why it is unviewable and urenderable

enter image description here

enter image description here

enter image description here

I'm using cycles, and even if it is a material problem, the tree should still render just as a blank thing, right? Is there something special I have to do in order for curves to render?


UPDATE

The tree renders fine in rendered view port.


Here is a stripped version of the .blend:

$\endgroup$
  • 1
    $\begingroup$ Check if your tree object is set to unrenderable in the outliner (little camera icon). Otherwise edit your question and provide more information like screenshots your settings and object properties. Also check animation/armature settings, see if they are not interfering with the object at the current frame. $\endgroup$ – Duarte Farrajota Ramos Nov 17 '16 at 0:04
  • 1
    $\begingroup$ Your tree curve has a disabled rendering option. As Duarte Farrajota Ramos said you need to click the little camera icon next to the curve in the outliner to make it renderable $\endgroup$ – Paul Gonet Nov 17 '16 at 1:34
  • 2
    $\begingroup$ Possible duplicate of Why is only one object being rendered? $\endgroup$ – Duarte Farrajota Ramos Nov 17 '16 at 2:28
  • $\begingroup$ @PaulGonet If these screenshots were taken at the same time, you can't actually see the selected tree. That is a different tree, but the selected one is a child of "treeArm". $\endgroup$ – JakeD Nov 17 '16 at 3:26
  • $\begingroup$ @Daniel Can you post a blend? $\endgroup$ – JakeD Nov 17 '16 at 3:26
2
$\begingroup$

The problem is that the layer it is on is disabled for the active blender layer:

enter image description here

Enable the box the arrow is pointing at.

$\endgroup$
  • $\begingroup$ Of course it's something stupid easy like this! I feel like an idiot for not checking! $\endgroup$ – Daniel Nov 17 '16 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.