0
$\begingroup$

My friend was having trouble with Blender launching. He has tried reinstalling, updating windows, and updating drivers, but always gets the same message in the console before the program closes-

UpdateDeviceParams: failed to set 44100 hrz, got 480000 hrz instead
found bundled python: C:\blender-2.78c-windows64\2.78\python

He also tried installing through Steam and got the same problem. Anybody know how to fix this?

$\endgroup$
5
1
$\begingroup$

You need to set your sound settings from 44k to 48k, here is how:

Before that, my windows version at the moment is version 1909. Windows settings might be changed in the future.

  • 1)Open settings
  • 2)Select "systems"
  • 3)Select "sounds"

  • 4)step4

  • 5)step5

  • 6)step6

  • 7)Apply and close all windows. launch blender.

If works, you may stop here, otherwise if you are stuck on grey screen in Blender:

  • 1) Windows Key + R
  • 2) type cmd . press Enter .
  • 3) press Windows Key enter image description here

  • 4) enter image description here

  • 5) Drag enter image description here

  • 6) Press Enter and it should work.

That is all I know. This minor issues happens a lot when you are using old pcs, laptops or old nVidia card as i know, because new apps might use new settings etc.

$\endgroup$
1
$\begingroup$

I had the same problem when I tried to run blender-2.90.1-windows64 - portable. Blender crashed immediately after the error message:

"UpdateDeviceParams: Failed to set 44100hz, got 48000hz"

Setting the speakers to 16bit, 48000Hz (or any other setting) did not work. However, the problem was gone when I did a software update to my AMD Radeon graphics card.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.