3
$\begingroup$

*Sorry for my bad English.

I'm trying to install and use Blender 2.79b on my new computer which uses Windows 10 64-bit. But it always crashes on startup. After double-clicking, a console pops up and shows "found bundle python: C:\Program Files\Blender Foundation\Blender\2.79\python". Then the window of blender show up with grey screen and it closes.

I tried to run it in compatibility mode for Windows XP, Vista, 7 and 8, updated the last GPU driver. I have installed Microsoft C++ Distributed 2005, 2008, 2010, 2012, 2013, 2017. I tried Blender 2.79 but it had the same problem.

My specs:
Intel Pentium G4400
8 GB RAM
Nvidia Geforce GT 1030

$\endgroup$
  • $\begingroup$ Try a daily build compiled with MSVC14 from builder.blender.org/download I had the same symptoms with all Blender 2.79 releases $\endgroup$ – BugGI Jun 9 '18 at 19:53
1
$\begingroup$

Please make sure that your:

  • Drivers are up to date (GPU especially).
  • The installation ran without problems.
  • Python is correctly installed and is the latest version (3.6.4 or 3.6.5).

Something else you can try is starting up cmd.exe (on Windows 10 you can just type that in the Start Menu and it will show up) and then from the console you can run Blender.

For example, assuming Blender is located on your C: drive and the path is "C:\Program Files\Blender Foundation\Blender\blender.exe", you'd type this line into your command window:

C:\Users\USER_NAME>"C:\Program Files\Blender Foundation\Blender\blender.exe"


EDIT: I think it's better I put this in my answer than a comment.

I looked up that error code which then led me to Blender's Web Manual. There are a list of commandline options to choose from, but for I suggest you run the following in cmd (single line):

"C:\Program Files\Blender Foundation\Blender\blender.exe" --debug-memory --debug-gpumem --debug-all > results.txt.

Please upload the results to any upload service and provide the link in your question, also check what output it gives specifically to memory

$\endgroup$
  • $\begingroup$ Thanks, I have just installed the lastest GPU driver, ran it by using cmd.exe, installed Python version 3.6.5. And I'm sure that the installation ran without problems. But the blender didn't start anyway. $\endgroup$ – congbinh May 24 '18 at 16:50
  • $\begingroup$ When you ran it through cmd, did it not write out any messages to the console window? For example, the message "AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead" prints out if I start up Blender through cmd (it still works though). Do you not get some other message(s) like this? $\endgroup$ – CosmicDevGuy May 24 '18 at 20:13
  • $\begingroup$ When I ran it through cmd, I found an error message "Error: EXCEPTION_ACCESS_VIOLATION". I searched it on google and I checked that I had installed the lasted GPU driver and Windows updates but it wouldn't help at all. $\endgroup$ – congbinh May 25 '18 at 5:48
0
$\begingroup$

I had tried all the solution I found, but it had been no use. So I downloaded Blender 2.78 and ran it, and it worked! Try other version if you have the same problem as me.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.