1
$\begingroup$

I have a scene where I want a car to look like it is on fire as I drive by it.

When changing to RenderMode, my motion track looks good (enough). It is in the right location and does not move relative to the car (masking to come later).

enter image description here

However, once I have rendered the image and composited it, the flame is distorted (horizontally stretched?) and in the wrong location.

enter image description here

I tried scaling the images to render size:

enter image description here

I also tried without the scale nodes, and with every permutation of the scale nodes. I have also tried rebaking the smoke, to no effect.

$\endgroup$
  • $\begingroup$ My guess is that your footage either has another aspect ratio or different dimensions. Check your Movie Clip properties and settings or better use an image sequence of the clip with a 1:1 pixel ratio and try to match the output dimensions in the first place. $\endgroup$ – brockmann Jun 9 '18 at 14:06
  • $\begingroup$ The footage has the same dimensions as an input. Like I said, whether or not I scale to render, the composited image looks the same. I'm also rendering out with an aspect ratio of 1x1 $\endgroup$ – NoobieStClair Jun 11 '18 at 1:05
  • $\begingroup$ Also, I rendered out a cube next to the flames, and the cube is not distorted. $\endgroup$ – NoobieStClair Jun 11 '18 at 1:56
  • $\begingroup$ UPDATE: I don't know what was wrong, but I deleted the smoke domain and recreated it, works now. $\endgroup$ – NoobieStClair Jun 11 '18 at 3:30
  • $\begingroup$ Sounds like you scaled your domain by accident...? $\endgroup$ – brockmann Jun 11 '18 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.