1
$\begingroup$

I am working on a scene where I have to track the camera motion and the motion of a prop with markers. I get a good camera track and a decent enough object track (It's just as a reference to the animators).

The tracking scene with the correct marker positions. My tracking markers for the object track are being scaled so that they are exactly where I need them to be in space and the camera track is scaled to match real world units from the set.

Just judging from the markers, everything is exactly where it needs to be, moves exactly as I need it to. However I am completely at a loss why I can't just have an object follow the object trackers movement. The object solve just puts it in a weird place behind/above the camera, moving the object by hand doesn't do any good either. It can't be that hard, can it? The object is not at all where the trackers are, nor is it moving correctly.

Just make the mesh follow the trackers (which already move fine in 3d space). Even using the follow track constraint instead of an object solver (cue desperation) and selecting a specific track out of the object track (which highlights correctly!) it still puts it all in a completely wrong position with a wrong motion. I tried parenting something to the object with the solver, to extrapolate the motion to my scale, to no avail.

Can anyone help me figure out what I have to do differently?

EDIT: Seems to be a scaling issue. Apparently Blender doesn't allow me to scale the camera track at all (for it to match real world units) without messing with my object track. Anyone has any idea how to avoid it? I fear it might be a bug?

Find the cleaned file here: http://pasteall.org/blend/index.php?id=52941

$\endgroup$
2
$\begingroup$

I think I got it working: http://pasteall.org/blend/index.php?id=52943

The key for aligning the "Tracks" mesh from the 3D Markers To Mesh operator is to add the object solver, choose tracking object and tracking camera, and then hit "Set Inverse". After that it should be lined up fine.

I deleted everything before in order to start from scratch.

Not sure how you setup your camera solution, but I used Tripod solving, as there is nearly no movement at all, so tracking only rotation should be enough. And when you do Tripod, you don't need so many markers. A handful is usually enough.
When you do the Object Solve you have to turn off Tripod of course.

What made the file behave a bit weird for me was not having the footage, so I was a bit confused which resolution to use. Using 256x256 seems to work though. Seems that when you solve and no footage is present Blender screws up the solve, as it tries to apply a square aspect ratio to the original resolution or something like that.

In fact, if you are only after the object's motion, you do not need a camera track at all. Simply ignore the camera motion and add an additional "object" in the clip editor so you can solve the object motion.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you! Upon further experimentation, the issue seems to be that blender really (REALLY) doesn't like that I have to use the scale values for the camera (here done with an empty parent, but set-scale under Orientation seems to yield similar results). Can you confirm that? And any idea how to get around that? Especially when having to have it work with real life prop-size + set dimensions? $\endgroup$ – Manuel Feb 24 at 14:01
  • $\begingroup$ Just use the scale slider in the Object panel. I think you don't even need to press the button Set Scale. Just drag the slider and the object solve AND the object with the constraint will scale accordingly. Might need to press play to trigger viewport update of the constraint. $\endgroup$ – sebastian_k Feb 24 at 14:17
  • $\begingroup$ The ground plane in my original file matches up with a real set element and it is vital all the scaling is correct not only in reference to the camera but to the set measurements. I can scale my object track just fine, but once the camera scaling had been changed, the object tracking doesn't seem to be in the position of the respective pointcloud anymore... $\endgroup$ – Manuel Feb 24 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.