5
$\begingroup$

On Graphicall there's a branch called OpenHMD, which basically should enable Blender to interact with VR glasses like the Oculus Rift. I do have a CV1 (consumer version) available, as well as a DK2 (development kit 2). When running the branch, I can open an OpenHMD window just fine, and I can also start the session as expected. The tracking even works well, when I move the Oculus, the viewport updates. Here's a screenshot:

enter image description here

But the Scene is never drawn on the goggles. I've followed the instructions of the manual here regarding switching the device to immediate mode. But that should mean I need to somehow move that window over to the Oculus. Thing is: I can't do that. The window snaps to all screen boundaries, I can never move it off-screen so it would show on the Oculus. Any ideas welcome.

$\endgroup$
1
$\begingroup$

Assuming you are using Windows:

The way to enable this is to switch the Oculus in Extended Mode, this is done by running a specific tool that Oculus delivers with the driver (example is https://www.reddit.com/r/oculus/comments/4nvy7o/rift_dk2_possible_to_activate_extended_mode/). Opening the HMD window in Blender should start the display in extended mode, if you can not view your desktop through the Oculus before moving the window, It is not activated correctly.

When using Linux:

If you are running Intel or AMD, this should work fine out of the box, with Nvidia, if you have recent drivers, you may need to enable Extended mode by adding AllowHMD in your Xorg, instructions can be found here: http://us.download.nvidia.com/XFree86/Linux-x86/378.09/README/xconfigoptions.html

$\endgroup$
  • $\begingroup$ Finally had some time to test it out. I am on the Windows Platform, and following the reddit link from up there gave me the same instructions I had already known. The key point however was that you need to turn DirectDisplayConfig to OFF in order to make OpenHMD work. Also its location seems to have changed: On my system it's in "C:\Program Files\Oculus\Support\oculus-runtime\DirectDisplayConfig.exe" $\endgroup$ – aliasguru Oct 11 '17 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.