1
$\begingroup$

I've just got a Wacom 3D pen for sculpting in blender and in the video Wacom released for the pen it shows you can navigate without using the keyboard:

https://www.youtube.com/watch?v=tcIVpiK3TXw

The first button is rotating the view like the middle mouse button and the second one in set for pan/zoom. Now, it is zooming when you click the button and move your hand while hovering over the screen, and the dragging, as the video suggests, is supposed to happen when clicking that button and tapping the screen with the pen tip.

The problem is that it is not dragging (or panning). (I cant find anywhere in the Wacom settings to control the hover and click/touch and click gestures)

Also, it is not a special feature for the 3D pen, it should work like this with all pens (it is working as shown in the video in Solidworks with the default settings).

$\endgroup$
2
$\begingroup$

You just have to emulate a 3 button mouse. Here's how to do it:

  1. Go to the User Preferences.
  2. Go to the Input tab.
  3. Check Emulate 3 button mouse.
  4. Hit Save User Settings.

From here on out you can rotate the view using Alt + click and dragging, zoom using Alt+Ctrl + click and finally navigate using Ctrl+Shift + click.

$\endgroup$
  • $\begingroup$ l'm not sure you understood me, it didn't solve the problem . I need to navigate using only the buttons and the feature i'm missing is panning,which supposed to be clicking and tapping with the stylus, like the video..or maybe I misunderstood you and if so, what did I get wrong? do I need to change blender pan shortkeys somehow? $\endgroup$ – Eden Yaloz Jan 3 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.