1
$\begingroup$

This is not so important for me, but still when i try to put a sub surface on with control 2 it won't work for me. I can always put it in the modifiers panel but it always bugs me why i cannot do it...

When i press Control + 2 it shifts the camera slightly...

I got emulate Numpad on and the shortcut keys are like they should be...

enter image description here

Can you please help me? Thanks, Anton Pogromskyy

$\endgroup$
1
$\begingroup$

You have the Emulate Numpad preference enabled. This is fine, but it means you will need to reassign your shortcut for adding SubSurf Modifiers. In Preferences search for keyboard shortcuts starting with the name "sub" and you'll find what you need.

Edit: In the screen shot you just added to your post, while it appears to be set up fine, what isn't obvious is that Emulate Numpad is overriding those. You'll need to change the shortcuts or disable Emulate Numpad.

Edit 2: Here's a screen shot of my configuration. I'm using Emulate Numpad, and so I've set up my shortcuts in the format of Alt Cmd Numpad1 (for numpad keys 0~5).

Emulate Numpad and customizing keyboard shortcuts

You can also see that I have not done so for Sculpt Mode, so you can compare. As soon as Emulate Numpad is enabled, Blender registers the horizontal row of number keys as numpad keys, and this is the reason for what's happening.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for answering so quickly! I have everything right, I got the emulate number pad and the short cuts are right. When I press, for example, control 0 in goes to camera view $\endgroup$ – AntonPg Aug 29 '17 at 13:44
  • $\begingroup$ No problem. What shortcuts do you currently have assigned for adding subsurfs? $\endgroup$ – Mentalist Aug 29 '17 at 13:47
  • $\begingroup$ I just edited my post, reload the page. $\endgroup$ – AntonPg Aug 29 '17 at 13:47
  • $\begingroup$ Thanks! It worked without emulate numpad but without the emulate numpad i cannot go in different views but thanks anyway!! $\endgroup$ – AntonPg Aug 29 '17 at 14:08
  • $\begingroup$ Wait, don't give up just yet. :-) I updated my answer again. $\endgroup$ – Mentalist Aug 29 '17 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.