0
$\begingroup$

This question already has an answer here:

enter image description here

Firstly, I apologise, I know this gets asked a lot and I've read through other answers, but I'm still not getting it. As far as I can tell I've done everything right. Can anyone see what's missing? That's a model of a moa that I'm trying to drop into a short film, but at this stage I'm just working with a still for the sake of colour matching. Basically, I hit "render" and just get the bird without the background... like I said in the title, I'm brand new to Blender so it's probably something fundamental.

Thanks in advance.

$\endgroup$

marked as duplicate by cegaton, Denis, batFINGER, David Aug 15 '17 at 16:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 4
    $\begingroup$ Background image itself won't appear in the rendered image, it's meant only for editing. A simple solution is to set up new texture for the world, see blender.stackexchange.com/questions/65212/…, but that's for Cycles engine while you're using Internal. You can just import image as plane and set it up in 3d view $\endgroup$ – Mr Zak Jul 15 '17 at 11:27
  • $\begingroup$ See this post: blender.stackexchange.com/a/38464/1853 $\endgroup$ – cegaton Jul 15 '17 at 14:12
  • $\begingroup$ Cool, that gives me an idea. I might just try a green-screen approach. I'll make a big bright green plane in the background, so I can export it, then chromakey the green out and combine the shots in software that I'm more familiar with. $\endgroup$ – An-Electric-Heart Jul 15 '17 at 22:48
  • $\begingroup$ Adding green in the background is not something I would recommend, given that you can export an image with a clean alpha channel straight our of blender. Just enable transparency (or "film transparent" if you are using cycles") and save in a format that supports an Alpha channel (OpenEXR, PNG, TIFF). There is no need to add something that you are going to have to take out, and that might bring other kinds of artifacts to the image. $\endgroup$ – cegaton Aug 15 '17 at 14:40
0
$\begingroup$

Background images do not show up in the render. They are typically used as a reference for modeling. There are a few ways to handle this, but the easiest, by far is to use the import images as planes add-on. Press ( ctrl + alt + U ). Select add-ons, and then type image into the search bar. enable import-export: import images as planes.enter image description here

At the bottom of the mesh menu (shift + a -> mesh) should be the option to add image as plane. After you successfully perform this part, the rest should be self explanatory.

I noticed in your picture that you had your rendering set to Blender Render. Blender had 3 different render engines. Blender Render is the default engine, but it considered outdated, and is only kept as legacy software. It is best to set the render engine to cycles. The results are more realistic and more modern.

enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.