1
$\begingroup$

so when I created the scene without the fire I got a clean image with no noise (using 256 samples),but when I added the smoke simulation and rendered a frame it became really noisy around the fire and especially on the grass.I tried everything and still can't remove the fireflies/noise from the scene.This makes me think that the animation will look even worse.What can I do to fix this?

$\endgroup$
1
$\begingroup$

First off:

Smoke (Volume Shader) makes the scene very noisy as Cycles needs to calculate the light go through the smoke which is made up of tiny particles which light has to scatter through, thus making it very noisy (samples define the amount of times it is calculated). I find that when dealing with large objects with volume shaders, such as smoke a minimum of 500 samples should be used (unless it's a test render).

Secondly:

The animation will not look worse as it essentially does the same process as rendering a single frame apart from doing this for the amount of frames the scene has. Therefore if the render time for a single image is 1 minute, an animation (in the same scene with same settings) with 100 frames will take approximately 100 minutes.

The Fix

First, as stated before increase samples. Next adjust the light settings. This Blender Guru article explains it pretty well. Also I would watch this video by Zacharia Reinhardt.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.