0
$\begingroup$

I cannot get rid of noise/fireflies in my glass shattering scene, rendering with cycles. I've tried all of the following suggestions:

  • Increasing Samples (up to 4000, still tons of noise)
  • Filter Glossy (from .5 to 20, still no fix)
  • Increasing Clamp (to 5)
  • Increasing light source (emissions doubled, still tons of noise)
  • Denoising (from .25 to 1, it works but makes the image too blurry)
  • Caustics (turned off and on, makes no difference)
  • Light Path Bounce min/max equal (both set to 8, that helped but did not fix)
  • Multiple Importance Sampling (turned on for all tests)

Is it possible I really need to go up to 10k samples? Or, maybe there is something wrong with my glass texture, which is just "Glass BSDF" with Roughness at .1 and IOR at 1.45?

EDIT: Everything follows almost exactly a tutorial by Blender Guru found here

Here are my renders: enter image description here enter image description here enter image description here

EDIT: Here's the render without the emission planes and with on sun light source instead. Any ideas?

enter image description here

$\endgroup$
  • 3
    $\begingroup$ You have a ton of emission planes. Mesh lights make noise worse. Can you either replace some of them with area lamps, or merge multiple planes into one large plane? $\endgroup$ – Scott Milner Apr 27 '18 at 23:49
  • $\begingroup$ Two questions (please use the edit link under your post updates as part of the question): 1- Did you set any samples on the render layer? (see: blender.stackexchange.com/questions/42908/…). 2- Can you post an image of the materials you are using for the glass? Please consider sharing your file so that others can inspect it and possibly find a solution. You can use blend-exchange.giantcowfilms.com to upload and paste the resulting link as part of your question. $\endgroup$ – cegaton Apr 28 '18 at 1:22
  • $\begingroup$ Thanks, glass texture is just "Glass BSDF" preset. I added the tutorial I'm following in my edit. Also, I should mention this render crashes my 2017 iMac every single time. (Memory: 32 GB 2400 MHz DDR4 | Graphics: Radeon Pro 580 8 GB | Processor: 3.8 GHz Intel Core i5) $\endgroup$ – BlueHelmet May 3 '18 at 22:33
2
$\begingroup$

I went with the following settings, which seemed to do the trick.

  • Removed the emission planes and replaced with a sun light source
  • Changed the color management to "Filmic" since that is supposed to be better with dynamic range
  • Used denoising to eliminate most of the grainy look
  • Increased the resolution of my animation to 1080p (not sure if that made a difference, but it looks better to me)

enter image description here enter image description here enter image description here enter image description here

$\endgroup$
1
$\begingroup$

If you want better quality of your renders, get rid of the emission textured objects and go for the lamps. They give off less noise, and make the render look much more better than before. I'm currently making a little animation that features a cup of coffee with steam, and features a painting, sofa, and a glass coffee table the cup is sitting on. I had noticed that with these emission materials, they give the glass and glossy materials a horrid shine, and will normally result in grainy looking objects. NOT GOOD! I would strongly recommend that you use the Lamp, Spotlight, or the Area lamps, as they are pretty easy to control and have a better and easier to use lighting (the sun is odd, as it lights up the WHOLE scene instead of a single area, which makes it only useful for outdoor scenes, in my opinion). For your particular project, I would probably use area lamps, as they would be a good substitute for the planes in the background. This lamp makes little noise, and is much more better in the use of lighting. As you can see bellow, there is no comparison in how different the renders look:

See? Looks super rushed and really fake. I must say, that noise in blender is one of the most annoying things to work around, as you need to put soooo much more effort in to ensure that your projects look professional. Now, lets try doing a simple render with the emission planes switched with area lamps... enter image description here

Now, as you may see, the glass looks 20X better! (sadly mine has a reflection but I'm not too worried about it at this time) This is with the area lamps, which give the room more better look. The glass no longer has light specks, and the room has a nicer feeling to it, and does look much better compared to before. I hope this helps with figuring out how to fine-tune the lighting to your needs. I think that once you do this simple change with the lighting, your project will look amazing! Hope this helps you out, and that you can make a super cool looking render in the end.

-Cody :D

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.