0
$\begingroup$

I rendered an animation and the frames by themselves don't look noisy, but when I put them together in a video every frame seems to be flickering and really noisy. The lights are purposefully flickering when the objects get pulled together, but not before. 128 samples, 1080p, tile size 256, default noise treshold, openaidenoiser, light bounces all on 10. Increasing the samples doesn't make a difference. https://we.tl/t-1CPYqX7jlt

$\endgroup$
4
  • $\begingroup$ Hello and welcome. While files, images, and external videos or links may be helpful additions they should not be the only way to obtain information about your issue. Don't make understanding your question rely on downloading a file, watching a video or visiting an external site. Use the builtin tools to upload images or gifs, along with thoroughly explaining the problem in written form so it can be indexed and searched for thus helping future visitors with similar issues. $\endgroup$ Commented Feb 3 at 21:46
  • $\begingroup$ Do you have this issue on individually stored frames or on a video? $\endgroup$
    – Lauloque
    Commented Feb 3 at 23:28
  • $\begingroup$ The frames by themselves look fine but when they are played in a video like in the link, mainly the wall are flickering and noisy. I rendered them as pngs. $\endgroup$
    – Arceus
    Commented Feb 4 at 10:43
  • $\begingroup$ You write that increasing the samples doesn't change anything. To what number have you increase/tested the sample count already? $\endgroup$
    – Marius
    Commented Feb 4 at 16:06

1 Answer 1

1
$\begingroup$

There is nothing inherently wrong with your render, your Sample count is just too low. When rendering an Image, the longer you render the less noise an image will have. When using the inbuilt denoiser, this noise pattern gets interpreted individually frame by frame. the more noise visible the more the denoiser has to guess how it should look like on every frame individually. In other words, the noisier the image the more the denoiser has to guess. As it guesses every frame individually (technical term: not temporal stable) the denoiser creates different patterns for each frame.

This is a normal behaviour of any denoiser that is not temporal stable.

What you can do to fix the issue:

  • Increase the sample count of your render. Try double the amount and only render 3 to 4 Frames of the animation. play these frames back and see if the artefacts persist. increase the number until you're happy with the result. then render the full animation. I recommend to choose the frames when the things are bundled up in the air.
  • Uncheck the denoiser in Blender and just render the noisy images. Then Use a denoiser in your editing software if yours does have one. Davinci Resolve (the paid version) does have one for example. These denoisers are temporal stable and will denoise your video not frame by frame but rather as a sequence. please be aware that this will not correct a video that is very noisy.
  • Use a paid Add-on like Pidgeon Tool Bag (https://blendermarket.com/products/pidgeontoolbag) To denoise your render temporally inside of Blender
  • Use a different Render Engine like Redshift (if my memory doesn't fail me) that has a temporal stable denoiser. This also costs money and i'm not sure if the denoise option of Redshift would actually be available in Blender
  • Render it using a Render Farm. Just google "Render Farm Blender" and you will find a bunch of options. This will cost money but let you increase your sample count to high numbers as they have very fast hardware.
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .