2
$\begingroup$

I have a mesh and on to that I have added a single vertex, which I'm extruding making lines on the body. I have added a Shrinkwrap modifier and when I extrude the vertex it goes up or down instead of moving along the surface of the mesh. I have checked and there is no snapping on.

enter image description here

$\endgroup$
1
  • $\begingroup$ I do not know how to solve this problem, but maybe you want to try freehand sketching instead. $\endgroup$
    – Dimali
    Apr 12 '17 at 12:49
1
$\begingroup$

The Shrinkwrap modifier tries to find the closest surface of the Shrinkwrap Target to move the vertex to. If the vertex is very far away from the Shrinkwrap Target then the vertex may appear to 'snap' to part of the object as the Shrinkwrap modifier is having a hard time determining which part of the mesh the vertex should be moved to.

Now, you may be thinking that this isn't the problem here as you can clearly see the vertex you are moving is very close to the surface. However, what you are seeing are the vertices in their new, shrinkwrapped positions. What the Shrinkwrap modifier sees are the original positions. You can see the original vertex positions by disabling the Show on cage button:

enter image description here

Your vertices are probably quite far away from the Shrinkwrap Target, which is causing the issue.

A very simple solution to this is to first Copy the modifier, so you have two Shrinkwrap modifiers:

enter image description here

Then Apply one of the Shrinkwrap modifiers (make sure you're in Object mode):

enter image description here

What this does is apply the new, shrinkwrapped positions to the vertices. Now if you disable the Show on cage button you will see the vertices are in exactly the same place. You can now continue extruding and translating and because the vertices are very close to the surface they should move very smoothly over it.

If you are moving the vertices a lot you will eventually start to see the same snapping problem appear, because, remember, even though the vertices appear on the surface, you are moving them away from the surface, in 3D space, altering their original positions. When this problem happens again you can just repeat the copy/apply process to apply the new vertex positions.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.