0
$\begingroup$

I started the animation of my project and I want to carry stones from one place to another. I am using rigid bodies on the stones so each one of them is an individual object. Here in the first picture are they in the initial position. enter image description here

But when I move the loader in a diferent frame the stones stay in the initial position like in picture 2 enter image description here

How can I move these stones with my rigged mesh (front end Loader)?

enter image description here

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ are you using BGE? $\endgroup$ – Tak Apr 7 '17 at 0:56
  • $\begingroup$ This is blender cycles. This is what I did: in the first 50 frames I let the rocks fall on the truck and the loader by simply animating with rigid bodies as there are hundred stones and I didn't wanted to place them one by one. Then I made the animation of the loader. I thought the stones will move with the loader but nope... I don't have a clue what to do right now. $\endgroup$ – NATURU NATURYU Apr 7 '17 at 2:32
  • $\begingroup$ Could you provide your file on blend-exchange.giantcowfilms.com to be able to have a look and help you $\endgroup$ – Tak Apr 7 '17 at 2:36
  • $\begingroup$ Sorry I don't want to post the file. But thanks anyways. $\endgroup$ – NATURU NATURYU Apr 7 '17 at 14:49
2
$\begingroup$

Rigid body objects only interact with other rigid body objects. To make the loader bucket "pick up" the rocks it will need to have rigid body enabled. As you are using an animation to move the bucket you should enable the animated option. You also need to set the collision shape to mesh so that the bucket will be hollow to allow the rocks inside it.

rigid body settings

example animation

You will also want to use similar settings for the truck.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi Sambler.Thanks for your answer. I did what you say but is not working for me. I will post the pictures on the post. They just move until they touch the bucket and then they (stones) stop movin while the bucket keep playing the animation alone $\endgroup$ – NATURU NATURYU Apr 7 '17 at 14:32
  • $\begingroup$ I don't know if it is because when I am animating the bucket I don't select the bucket but only the armature which is in pose mode and the rocks works maybe only in object mode. Is there maybe a way to apply the armature position to the loader in object mode, so that the stones maybe get the movements applied too? $\endgroup$ – NATURU NATURYU Apr 7 '17 at 14:43
  • $\begingroup$ I selected the deforming option and put friction on 1 and made the animation a little slower and is working a little better although some of the stone still falling to the floor. Picture on the post $\endgroup$ – NATURU NATURYU Apr 7 '17 at 15:44
  • $\begingroup$ Ok, I got it. The stones have to be very big to keep the movement with the truck. Thanks Sambler and Tak. $\endgroup$ – NATURU NATURYU Apr 7 '17 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.