4
$\begingroup$

I am trying to enable yafray in the latest blender release 2.78c. When I try to turn on the add-on I get the following...

Traceback (most recent call last):
File "C:\Program Files\Blender Foundation\Blender\2.78\scripts\modules\addon_utils.py", line 330, in enable
mod = __import__(module_name)
File "C:\Users\Professor Black\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\yafaray_v3\__init__.py", line 70, in   <module>
from . import io
File "C:\Users\Professor Black\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\yafaray_v3\io\__init__.py", line 21, in <module>
import yafaray_v3_interface
File "C:\Users\Professor Black\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\yafaray_v3\bin\yafaray_v3_interface.py", line 28, in <module>
_yafaray_v3_interface = swig_import_helper()
File "C:\Users\Professor Black\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\yafaray_v3\bin\yafaray_v3_interface.py", line 24, in swig_import_helper
_mod = imp.load_module('_yafaray_v3_interface', fp, pathname, description)
File "C:\Program Files\Blender Foundation\Blender\2.78\python\lib\imp.py", line 242, in load_module
return load_dynamic(name, filename, file)
File "C:\Program Files\Blender Foundation\Blender\2.78\python\lib\imp.py", line 342, in load_dynamic
return _load(spec)
ImportError: DLL load failed: The specified procedure could not be found.

I am not sure how I go about addressing this error. I have looked around and it is not clear, to me at least, what Python package I should be using with yafray.

Anyone have experience with this?

Thanks in advance. UPDATE

I uninstalled blender and reinstalled blender using blender-2.78c-windows64.msi

when i launch the program i get

AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
found bundled python: C:\Program Files\Blender     Foundation\Blender\2.78\python

Then I downloaded yafaRay.v3.1.1- beta.build.for.Blender.2.78.MinGW.Win7.Win8.1.Win10.64bit.zip and installed from file as suggested, yielding

 reloading addon: yafaray_v3 1488561782.9271553 1489010961.1245487        C:\Users\Professor Black\AppData\Roaming\Blender    Foundation\Blender\2.78\scripts\addons\yafaray_v3\__init__.py
Modules Installed from 'C:\\Users\\Professor   Black\\Downloads\\YafaRay.v3.1.1-  beta.build.for.Blender.2.78.MinGW.Win7.Win8.1.Win10.64bit.zip' into   'C:\\Users\\Professor Black\\AppData\\Roaming\\Blender    Foundation\\Blender\\2.78\\scripts\\addons' ()
$\endgroup$
  • $\begingroup$ What if you exit Blender, run it again and try to activate the addon? $\endgroup$ – lemon Mar 7 '17 at 16:58
  • 1
    $\begingroup$ Windows or Mac machine? I cannot reproduce the issue on Linux - downloaded the latest version > User Preferences > Install from file without any errors... @TheCodeNovice $\endgroup$ – p2or Mar 7 '17 at 17:30
  • $\begingroup$ @poor I am on a Win10 64bit version. I do not get any errors when i try and click install from file, only when i try to enable the yafray addons. $\endgroup$ – TheCodeNovice Mar 7 '17 at 23:22
  • $\begingroup$ @lemon I get the same error each time i open blender and try and enable the addons $\endgroup$ – TheCodeNovice Mar 7 '17 at 23:24
  • 1
    $\begingroup$ The thing is that all versions of it marked as "unstable" (beta) and they recommend using the latest so I'd definitely do that (don't see any reason switching to the old 1.2 versions, you can convert old materials within the new one). Also tested the latest addon on linux to confirm poor's comment, except one negligible color managment issue, no madness @lemon $\endgroup$ – brockmann Mar 8 '17 at 10:05
2
+50
$\begingroup$

We can indeed enable or disable the addon only once per session (should be reported here: http://www.yafaray.org/development/bugtracker/yafaray).

Apart from that the Addon working fine on Windows (64 bit) :

enter image description here

First remove all the previous Add-ons and Versions of Yafaray, then download Yafaray 64bit from here, go to User Preferences, Addons, Install from File, select the zip file and enable the addon, done.

If the error message comes up restart blender and enable/disable the addon.

$\endgroup$
  • $\begingroup$ thanks for your answer, can you update it with what python version are you using, the packaged one or a different one. $\endgroup$ – TheCodeNovice Mar 8 '17 at 12:32
  • $\begingroup$ It's just the default version that comes with blender 2.78c (otherwise I had mentioned that). In case your python versions messed up, I recommend downloading blender as zip archive. Also make sure you are downloading the correct version of yafaray for your system @TheCodeNovice $\endgroup$ – brockmann Mar 8 '17 at 12:55
  • $\begingroup$ Do i need to get rid of other versions of python on my computer. Like clear out my environment variables etc... $\endgroup$ – TheCodeNovice Mar 8 '17 at 17:07
  • $\begingroup$ Blender comes with it's "own" python, no need to setup environment variables (in general) so I doubt there is a python version error, if it were the wrong version blender wouldn't come up at all. However I don't know your system and again blender's ".zip" variant is very handy (in such cases) @TheCodeNovice $\endgroup$ – brockmann Mar 8 '17 at 18:47
  • 1
    $\begingroup$ @TheCodeNovice phew. I'm glad that it's working now... $\endgroup$ – brockmann Mar 9 '17 at 8:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.