1
$\begingroup$

Here's the problem: Whenever I try to import or export anything(.stl and .obj), I get the following error:

Traceback (most recent call last):
File "C:\Users\owlteagames\Downloads\blender-2.78-windows64\2.78\scripts\addons\io_mesh_stl__init__.py", line 203, in execute from . import stl_utils
File "C:\Users\owlteagames\Downloads\blender-2.78-windows64\2.78\scripts\addons\io_mesh_stl\stl_utils.py", line 31, in import contextlib
File "C:\Users\owlteagames\Downloads\blender-2.78-windows64\2.78\python\lib\contextlib.py", line 4, in from collections import deque
File "C:\Users\owlteagames\Downloads\blender-2.78-windows64\2.78\python\lib\collections__init__.py", line 10, in from operator import itemgetter as _itemgetter, eq as _eq
File "C:\Users\owlteagames\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\operator.py", line 5, in from .hmd import HMD SystemError: Parent module '' not loaded, cannot perform relative import

I don't really know what any of this means, but I've noticed...that the problem seems to be centered around a bunch of different Python scripts.

I have been researching this for three days without any luck. My boss is about to fire me for "Claiming I Know How To Use Blender When I Obviously Don't." I've uninstalled and reinstalled Blender, and no help. I'm afraid that if I roll back to an earlier Blender version, that all my files opened in the new Blender will be incompatible!

I even tried going into the preferences under files paths, to see if the lack of connections to everything was the culprit- the boxes next to FONT, TEXTURES, RENDER OUTPUTS, etc were all empty except for the TEMP path. I hooked up what I could- fonts, scripts, but the same error appears- completely unaffected by my path connections effort.

Many Thanks to the person able to help, and thank you for reading this even if you can't help! Let's save my job! Haaa...

$\endgroup$
  • $\begingroup$ For starters, it might be a good idea so add some info about the settings you used in the exporter. Next, don't start with your model, use the default cube. And make sure that you select it and then check the "Selection only" box. Works for me in the latest version for both stl and obj $\endgroup$ – metaphor_set Dec 1 '16 at 2:02
  • 1
    $\begingroup$ The last item is where the error is coming from File "C:\Users\owlteagames\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\operator.py", line 5 - this is in your preferences folder from a script that you have installed, maybe an addon you downloaded, I expect it isn't installed correctly. Clear out (or temporarily move) C:\Users\owlteagames\AppData\Roaming\Blender Foundation\Blender\2.78\scripts and try. $\endgroup$ – sambler Dec 1 '16 at 4:23
1
$\begingroup$

thank you metaphor_set and sambler!

a combination all of your suggestions helped. I had tried to download a theme, and I guess it didn't want to work right. Anyhow, I deleted my pycache, restarted, and made sure to select Selection Only on export, and change the type from Batch to Object. After that, things started working again.

thanks again! I hope this helps somebody else!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.