2
$\begingroup$

I have a scene with a particle emitter and a second scene with the actual particles. enter image description here I separated them so I could have more control over motion blur.

When I try to render the animation, it renders both scenes on every single frame, but the particles are only in the scene for a couple frames in the end.

So my question is: can I tell the compositor to render and combine two scenes for only a few frames at the end instead of rendering and combining both scenes for the entire clip? I imagine it would save render time.

$\endgroup$
2
$\begingroup$

You can enable and disable rendering Render Layers by clicking on the checkbox for a layer in the Render Layers tab in the Properties area.

You're also able to create keyframes for this setting by either clicking on the checkbox with the right mouse button or pressing I while the mouse cursor is over the box.

render layers

$\endgroup$
  • $\begingroup$ Thanks for the idea but I only have one Renderlayer but multiple scenes. $\endgroup$ – eromod Mar 5 '17 at 15:52
  • $\begingroup$ @eromod Your screenshot indicates that you have (at least) one render layer per scene. You should be able to deactivate a render layer in a scene even if it's the only one in that scene. $\endgroup$ – binweg Mar 5 '17 at 16:02
  • $\begingroup$ Your right, that did the trick $\endgroup$ – eromod Mar 5 '17 at 16:05
2
$\begingroup$

You can add a Switch node in the compositor (Shift + A > Layout > Switch), and keyframe which input it uses by hovering over the checkbox and pressing I.

enter image description here

$\endgroup$
  • $\begingroup$ Very useful node, thanks for the tip. But it still renders both scenes and discards the unused one when the switch is off. So it uses up rendering time. It works if I mute the node, but I cant seem to keyframe muting a node... $\endgroup$ – eromod Mar 5 '17 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.