6
$\begingroup$

I have this camera just "waveing" due to an s-shake (Built-In Function modifier for the rotation keyframing), and I need to use the motion of the camera to rotate and blur an image like a post processed motion Blur. I tried to use the vector Pass while rendering but this only works if there is an object moving in the scene. I don't want just to import the image as a plane and render with motion blur cause this won't be practical if you have muliple scenes. Basically something like this:

that is

a pass that can tell the compositor in which direction the motion happens.

Is there any way of doing this?

$\endgroup$
  • $\begingroup$ I just tried to do what you are describing and it just worked for me. I used a static Image-Plane and only rotated the camera with a noise modifier. Then I was able to blur the image using the vector pass in the compositor. I believe that's what you need, right? Or am I misunderstanding you? $\endgroup$ – michaelh Dec 22 '17 at 14:55
  • $\begingroup$ can you please explain how you did it? $\endgroup$ – Fabrizio Dec 22 '17 at 17:54
  • $\begingroup$ If you export the vector pass of animated camera and apply to image it won't look right because you have to rotate the image according to camera movement. Also the vector pass values depend on the distance of the objects (in this case a plane to the scene. If you rotate the camera on local Z axis it won't matter but if you include other rotation axis the distance matter). $\endgroup$ – Rumen Belev Dec 26 '17 at 17:26
3
$\begingroup$

Here is what I did to get it to work. (I didn't add an explanation to my comment, because I essentially just did, what you described in your question.) Anyways, here it goes:

I'm using Blender 2.79.

My Scene only contains a camera and an image plane, which I added via "Images as Planes". Then, I added keyframes to the Camera Rotation. I modified X-, Y-, Z-Rotation with a Noise Modifier.

3D_View Kitty_nodes Curves

I turned off Motion Blur in the Render Tab

noMotionBlur

And here are the Render Passes I used:

RenderPasses

Then, turn on Compositing under Post Processing.

This is my Node Setup to add the Vector Blur:

Nodes

Which gives me this result:

Result

Note, that the image plane is NOT moving.

Have a look at the blend file:

EDIT:

A little side-note, that I've just noticed:

When I look at the vector pass (by Ctrl + Clicking with Node Wrangler Addon) I only sometimes see the actual colors in the viewer. Other times the viewer shows nothing. But this seems to be only an issue with displaying it, because, when I left-click on the viewer, I actually get a values at the cursor position. This can also be confirmed by saving it out. - The I get this picture, even though the viewer shows nothing:

vector

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.