0
$\begingroup$

I have been trying to install several addons, but when I click on the zip to install it, it doesn't show up! I have several addons installed from a few months ago that worked, including animation nodes and sverchok, but now it doesn't work! Python isn't working on my computer as of late and needs to be reinstalled, so is that the problem? Also, I have tried the unzipped version and the init.py file.

$\endgroup$
0
$\begingroup$

The file you should select will be a .py file, that can be found inside the .zip file. (Use WinRAR or 7Zip to open it) if the init.py doesn't work and it's the only file in there, you could have a corrupt download. What plugin are you trying to install?

Here are the specific installation options for installing the Mitsuba render engine:

First, download this file, then follow the following instructions:

Unpack this file and move the resulting mitsuba folder into your Blender scripts/addons folder. After you do this, restart blender then go to user preferences, then find mitsuba in the addons tab and enable it. Then, you should be able to select Mitsuba as the currently active renderer (click either Cycles or Blender Render above the 3D view.

In the main scene tab, you will need to set the path to the main renderer executable (mitsuba.exe on Windows, Mitsuba.app/Contents/MacOS/mitsuba on MacOS, /usr/bin/mitsuba on Linux).

Then, to install the spaceship generator, go to this link and select "Clone or download" and download .ZIP

Then open the .ZIP and drag the spaceship_generator.py onto your desktop. Then, in blender, go to the addons tab and choose 'install from file'. then select the spaceship_generator.py through the dialog box. Afterwards, just enable the addon and you're good to go.

$\endgroup$
  • $\begingroup$ I'm trying to install the mitsuba rendering engine and the spaceship generator. $\endgroup$ – Kaixon Nov 9 '16 at 17:49
  • $\begingroup$ @Kaixon check my edits $\endgroup$ – Josh Silveous Nov 9 '16 at 18:05
  • $\begingroup$ I've also been having trouble with hard surface modeling for robots, weapons, etc... and I can't buy Hard Ops or Boxcutter. Any options? $\endgroup$ – Kaixon Nov 9 '16 at 18:10
  • $\begingroup$ @Kaixon Glad it helped! If this solved your problem, please accept this as the answer (the green checkmark to the left). If you have more questions, feel free to create a new post and I'd be more than happy to help. $\endgroup$ – Josh Silveous Nov 9 '16 at 18:12
  • $\begingroup$ I am not a user and can't ask again for about 40 minutes, so I am also having trouble downloading MakeHuman. $\endgroup$ – Kaixon Nov 9 '16 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.