1
$\begingroup$

I know this question has been asked before, but I can't really find a solution. This was happening years ago too I think, so... I'm pretty stuck. I've even re-installed my entire os since then, but I remember addons working at some point.

The two addons I need are these; https://github.com/sugiany/blender_mmd_tools https://github.com/ousttrue/pymeshio

I've tried to install them in a couple different ways - I tried using 'install addon' and using the zip, but nothing. I tried to put the extracted folders into the addons folder of my Blender installation, still nothing.

When I click on the button to install an addon from user preferences, it just does nothing. It doesn't ever appear in the list, and I can't see any errors. This happens every single time I try to install the addons, just nothing happening.

I tried this with a portable install as well, there was no difference.

I realize I'm probably doing something very wrong like an idiot, but I would appreciate some help. Thank you.

$\endgroup$
  • 1
    $\begingroup$ Can you please specify your platform & the version of Blender you are using. $\endgroup$ – Derrick Feb 15 at 14:06
  • 1
    $\begingroup$ Both those addons seemt to be rather old - one is from 2015, made for 2.67, and the second one reportedly doesn't even work with Blender 2.79. $\endgroup$ – Jachym Michal Feb 15 at 14:09
  • 1
    $\begingroup$ Both add-ons are just too old... $\endgroup$ – brockmann Feb 15 at 14:09
  • 2
    $\begingroup$ Ask the original author to update the addon for 2.8x, otherwise you have to use an older version of blender @Ethan $\endgroup$ – brockmann Feb 15 at 14:22
  • 3
    $\begingroup$ Alright. Thank you all for your responses- I'll try an older version. Thanks again. $\endgroup$ – Ethan Feb 15 at 14:26
-1
$\begingroup$

These might be the possible errors:- 1. Check if there is sufficient space in the drive your os is installed. 2. Check if the addon downloaded is of correct windows architecture I.e. 32 bit or 64 bit. 3. Check if the blender version you are using is same as mentioned for the addon. 4. Install a stable blender release instead of nightly build or alpha build. 5. Check that the python version you are using match the one on which the addon is scripted. 6. Check if the addon is complete and is not missing any command line.

If it still doesn't work you may have a error or bug report on the respective page.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Either way, you can't make them work with 2.8x. Also blender comes with python... $\endgroup$ – brockmann Feb 15 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.