13
$\begingroup$

I am trying to use the Alt+Right Click to select edge loops in Linux Mint but this shortcut doesn't work it is already used for Linux to reduce a window. I have checked the keyboard shortcut but it doesn't appear.

$\endgroup$
  • $\begingroup$ The idea that an Operating System would override an application keyboard shortcut when there has been a key specifically for operating system shortcuts since 1994... blows my mind. $\endgroup$ – Xtremity Aug 15 '16 at 0:57
  • $\begingroup$ Some of these operating system shortcuts trace their lineage back to the late 80s. I'm specifically thinking of bindings for twm, the window manager commonly used with the MIT X11 distribution. $\endgroup$ – Mutant Bob Aug 8 '17 at 19:59
16
$\begingroup$

Keyboard shortcuts on the OS override those in Blender.

Two possible solutions:

  • Change the keyboard shortcuts on blender and avoid conflicting key combinations.

The main disadvantage custom shortcuts is that it's hard to follow tutorials or other help. If you work with blender on other computers your shortcuts will not match. Resetting to factory defaults will also result in the loss of your custom settings (unless you save them to a file).

  • Reassign the keyboard shortcuts on the OS using key-combinations that are not used in blender.

(The way I deal with it is by re-assigning the Linux keyboard shortcuts so that Alt of Ctrl keys are not used by the OS, but use the super (windows) key instead).

On Linux Mint open the system settings and navigate to "Windows".

enter image description here

and select the super key to move or resize windows:

enter image description here

$\endgroup$
  • $\begingroup$ Or the Disabled option for the resize windows key. $\endgroup$ – Danyl Bekhoucha May 6 '17 at 15:17
3
$\begingroup$

You can reassign that to another key combination.

Open up User Preferences (CtrlAltU) and click the Input tab, then click 3D View, Mesh, Loop Select. You can enter a new key combination by clicking the button that says Alt Select Mouse.

enter image description here

$\endgroup$
3
$\begingroup$

On Ubuntu with Blender 2.76b Alt + Shift + click worked for me instead of Alt + click without changing any other shortcuts.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.