5
$\begingroup$

I use Mac OSX 10.9.5. A year ago, I downloaded 2.75a, and today, I downloaded version 2.77a. I downloaded both via .zip file from blender.org and dragged each into the Applications folder of my Mac.

In 2.75a, I had done some painstaking remapping to accommodate my Magic Mouse and Apple Wireless Keyboard, in addition to a pretty shiny custom theme. I didn't want to redo these settings.

How could I transfer my old settings into the new version? Apparently due to my method of download, "Copy Previous Settings" did not show on the splash screen. I searched "Copy Previous Settings" in the new version via the spacebar, and it returned an error: "Users/aubrie/Library/Application Support/Blender/2.76 does not exist". From this, I figured how to copy my old preferences.

$\endgroup$
3
$\begingroup$

You can always use the new Blender Cloud Sync addon. It requires a Blender ID (free) and the addon (free). It allows you to upload your preferences to the cloud, and download them anywhere in Blender.

Addon Gif (Image from cloud.blender.org)

$\endgroup$
  • $\begingroup$ "This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – batFINGER 10 hours ago." This is what I did. So what's the problem? $\endgroup$ – cigar_matt Jun 19 '18 at 19:11
  • $\begingroup$ In case this helps others: When I switched from 2.79b to 2.80, my old method didn't work, so I used this cloud sync add-on and it worked great. I had to download the add-on (directly from the .zip file, no need to unzip) to both 2.79b and 2.80, sign in within Blender (using this other add-on: blender.stackexchange.com/questions/141746/…), upload settings in 2.79b, then download the settings to 2.80. $\endgroup$ – Aubrie Aug 4 at 19:33
2
$\begingroup$
  1. Find Users/yourname/Library/Application Support/Blender/2.75/config/userpref.blend
  2. Right click and select Copy "userpref.blend"
  3. Navigate to Users/yourname/Library/Application Support/Blender/2.77/config/
  4. Right click and select Paste Item
$\endgroup$
  • 1
    $\begingroup$ Aubrie, are you sure about that destination? Unless I'm reading it wrong, you're copying the "userpref.blend" file right back into the same location you copied it from. Also, since I think your answer applies to Windows machines, too, it might be more general just to do a search of the drive containing the operating system for the file "userpref.blend", rather than trying to navigate to the specific location. On some windows machines, the "userpref.blend" file is in a hidden folder, which cannot be navigated to by "ordinary" means. $\endgroup$ – brasshat Jul 3 '16 at 1:19
  • $\begingroup$ @brasshat You're totally right. I committed a typo. Step 3 should have said 2.77, not 2.75. Fixed it now. Good idea about conducting a normal search. That might get messy if someone has multiple previous versions of Blender installed. $\endgroup$ – Aubrie Jul 3 '16 at 1:31
  • $\begingroup$ Aubrie, I do have multiple previous versions of Blender installed, and when I just tested it for the answer, It did find the previous userpref.blend files for each one. But expanding the search results just a bit, it showed the folder containing each of the separate userpref.blend files, so it was easy to figure out which went with 2.75, and which went with 2.71. $\endgroup$ – brasshat Jul 3 '16 at 22:48
  • $\begingroup$ @brasshat That's good to know! I should clarify that in my original questing, I didn't know to search for "userpref.blend". Navigating to specific folders was how I learned that "userpref.blend" is the thing I needed. $\endgroup$ – Aubrie Jul 5 '16 at 22:49
  • $\begingroup$ I dragged both Scripts and Addons from the 2.78 to the 2.79 folder and it worked great. $\endgroup$ – MicroMachine Jul 12 '18 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.