1
$\begingroup$

Most of the time when I try to move a vertex or an edge, instead of translating that, it extrudes it, it creates another face or, vertiex or whatever.
I do not really get why it behaves like that. I hope I explained it in depth. I am sorry if this is a duplicate post but I could not find anything!

selected vertex before being moved

selected vertex after being moved, with a vertex still in the original location

$\endgroup$
  • $\begingroup$ You're pressing G instead of E to move it correct? $\endgroup$ – Luka ash Apr 19 '16 at 13:24
  • $\begingroup$ No sir , I am using the axis. And no I am not extruding. I think I will post an image to explain better. $\endgroup$ – Mihail Georgescu Apr 19 '16 at 13:32
  • $\begingroup$ Ok I updated and posted 2 images. I hope it explains the behaviour. For a beginner all this is very confusing. $\endgroup$ – Mihail Georgescu Apr 19 '16 at 13:41
  • 1
    $\begingroup$ It looks like you have two vertices in the same place. Remove doubles (select the whole mesh with A, then pres W-->Remove Doubles) and it should work fine. $\endgroup$ – Paul Gonet Apr 19 '16 at 13:52
  • $\begingroup$ @MihailGeorgescu Doing @ then their username (Like i did at the start) will notify the user that you replied, tell Paul that it worked so he can post it as a answer and you can accept. :) $\endgroup$ – Luka ash Apr 19 '16 at 14:17
2
$\begingroup$

Paul Gonet solved your problem in the comments, but here is how you can spot the problem yourself, and a bit more detail for future reference.


You are not making a new vertex but rather moving only one vertex when there are two in the same place.

You can easily spot that problem, double vertices, by looking at the selection color of the edges. In your image below I highlighted in red the edge you should watch out for. It is not selected, that means that it is not connected to the vertex you do have selected (and thus there is a double vertex hiding there).

Whenever you select a vertex all the edges connected to it should be the selected color (the default is orange) around the vertex (the whole edge will not change color, the selected color fades out along the edge).

unselected edge highlighted in red

You can select the second vertex that is hiding there, change the shading mode to Wireframe in the 3D view header or by pressing Z. Now select one of the vertices that are there, then hold Shift and select the second.
You can also use border select B, circle select C, or lasso select (hold Ctrl and drag with the LMB LMB held) to easily select double vertices.


To get rid of the problem you can use the Remove Doubles operator or Merge them. Both are accessible in the Tools tab of the tool shelf and many other ways.

Remove Doubles (W then R) will go through every vertex that is selected and see if there are any within its merge distance if there are, then it will merge them.

Merge (AltM) can be thought of as a manual version of the remove doubles command, but with much more control. For a scenario like you have where the two vertices are in the exact same place, any of the first three options will work fine (and do the same thing).
merge options

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.