1
$\begingroup$

Is there a way to use Project from view without the resulting UVs scaled to match the aspect ratio of the image?

For example, if I unwrap with Project from view the result looks like this:

enter image description here

I want it to be exactly how the mesh appears in the 3D view, e.g.:

enter image description here

Is this possible?

$\endgroup$
4
$\begingroup$

It is possible. Plain UV Unwrap and Project from View commands have the option Correct Aspect to take into account currently displayed image's aspect ratio. The image must already be opened and displayed in the Image Editor before unwrapping.

EDIT: It seems this feature only works correctly, when the active render engine is anything but Cycles.

Checking Orthographic also avoids perspective distortion if you happen to unwrap from Ortho view:

1a

Ortho or not, the resulting UV map is always of the right proportion by using Correct Aspect, even on images with aspect ratio far from 1:1 (this one after scaling down the UV map proportionally):

2a

| improve this answer | |
$\endgroup$
  • $\begingroup$ Strange.. Correct Aspect is enabled by default, however the result is scaled regardless if it is enabled or not. Perhaps a bug? Tested on linux with 2.68a and 2.69. $\endgroup$ – gandalf3 Nov 25 '13 at 0:10
  • 1
    $\begingroup$ @gandalf3: I also tested on those versions (in Ubuntu) with images of various aspect ratio, and Correct Aspect worked fine for all of them. Can't figure out what goes wrong in your case. $\endgroup$ – Adhi Nov 25 '13 at 1:11
  • $\begingroup$ I'm on Arch, but I tested with the official builds from blender.org.. Could you upload a .blend? Here's the one I've been testing with. $\endgroup$ – gandalf3 Nov 25 '13 at 1:37
  • $\begingroup$ Here's my test blendfile. In the file, I tried Project from View on a plane and a cube, and it worked correctly on both. Tried yours, and curiously it doesn't work on that image. Maybe it has something to do with image format, still testing it. $\endgroup$ – Adhi Nov 25 '13 at 1:57
  • 1
    $\begingroup$ @gandalf3: I linked the image in your test file to mine, and unwrapping the objects using its aspect ratio works. There's gotta be some different setting in your test file. $\endgroup$ – Adhi Nov 25 '13 at 2:13
2
$\begingroup$

It appears that this is caused because there is no material setup for the plane object.

From this bug report:

Correct aspect for Cycles uses material's image, not face texture (because Cycles doesn't have face textures).

In your ca[s]e [the plane] doesn't have any materials. If you'll create new material for [the plane] and use 100.png as Image Texture for it aspect correction will go fine for you.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.