2
$\begingroup$

I am trying to import a video to use as a background. I used cycles render but the video doesn't show up. I uploaded the video using video editor, then added the scene then added alpha over to the images. I used node editor to do the same thing and the video isn't showing up. I tried to find videos online but everyone is using blender render, the problem is the texture of the object I have only shows up in cycles and not blender render and I want to be able to see everything. Is there a way I can view the video?

the video is a .mov file but it is very big about 500MB.!

here is the rendered image

here is the second part of the compositor, I couldn't fit it all in one screenshot

enter image description here

here is my VSE editor enter image description here

that was all I did.

$\endgroup$
  • $\begingroup$ the video was quite large, is that a problem? $\endgroup$ – user2883800 Nov 24 '13 at 1:55
  • $\begingroup$ Nope, if you have enought RAM... It rather seems to me that you haven't turned on the "transparent" setting in 'Render' panel > 'Film' section. $\endgroup$ – Polosson Nov 24 '13 at 2:02
  • $\begingroup$ it worked, I tried transparent before and it didn't work. I probably didn't wait for it to fully render. $\endgroup$ – user2883800 Nov 24 '13 at 2:08
  • 1
    $\begingroup$ OK, so you can answer your own question :) ! $\endgroup$ – Polosson Nov 24 '13 at 2:10
  • $\begingroup$ Perhaps try connecting the 'Alpha' output of the render node to the 'Fac' node of the AlphaOver node? $\endgroup$ – Callum McLean Dec 16 '13 at 0:39
1
$\begingroup$

You first need to check the "Transparent" check box, under the subsection "Film" of the tab "Render" (the icon is a camera), on the "Properties" panel.

enter image description here

Then you need to connect the "Alpha" output from the RenderLayer to the "Fac" (Factor).

enter image description here

And, finally, where I have blue, you would connect your video.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.