4
$\begingroup$

I am trying to apply Physics effects to cubes I have created by using the "copy from Active" command.

So this cube has Collision, Soft Body and Rigid Body settings:

physics settings

I selected my target objects (all the cubes except the ones on the front row) with Border Select (B) in Object Mode, then my source object via (Shift+LMB):

all cubes selected

Then "copy from active":

copy from active

And then I think it doesn't work, because when I click on just one of these cubes, they only have Rigid Body enabled, not Collision or Soft Body:

physics settings

And indeed, they behave very differently than the front row:

animated gif of the cubes behaving differently

So, I'm trying to understand why "Copy from Active" didn't copy everything from active - if that's normal or if I did something wrong.

$\endgroup$
4
$\begingroup$

The command Copy from Active belongs to the Rigid Body Tools panel, which is a subcategory of the Physics Tab:

enter image description here

As stated by the Hint, Copy from active is just referring to the

Rigid Body settings

and not to the whole physics settings. Rigid body physics is treated in a different way.


You can copy the other physics settings from the active object of the selection by Making Links (Ctrl+L) and choosing the Modifiers option.

$\endgroup$
  • $\begingroup$ Thank you! I selected the target objects/cubes first, then one on the front, and clicked on Making Links -> Modifiers but the target objects now have 2 physics settings (soft Body and Rigid Body) instead of three (Collision was left out). I also realized the origin wasn't at the center of geometry for the back cubes, but that's another thing... $\endgroup$ – MicroMachine Dec 20 '15 at 3:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.