5
$\begingroup$

I don't know how but in the Text Editor, as I was editing a script, I disabled inserting (i.e. keystrokes overwrite current text instead of inserting a new character). how do I re-enable it?

I've tried:

  • Shift+0
  • Clicking Insert on the on-screen keyboard
  • Restarting Blender
  • Opening a new script
$\endgroup$
2
  • 5
    $\begingroup$ For me pressing insert on the keyboard toggles this behavior $\endgroup$
    – gandalf3
    Dec 12, 2015 at 19:40
  • 1
    $\begingroup$ have you solved this yet? $\endgroup$
    – David
    Dec 19, 2015 at 4:43

2 Answers 2

1
$\begingroup$

You pressed the insert key on your keyboard. It's traditionally above the delete key. This is common behavior, and will do the same thing in other applications as well. Pressing this will toggle between 'insert mode' (normal mode) and 'overwrite mode.'

$\endgroup$
0
$\begingroup$

I had this issue, stuck on overtype, pressing Insert didn't help.

The shortcut keys behavior in Blender dictates that it only work when the mouse cursor is inside the designated window boundaries.

When I hovered the mouse over the text editor, pressing Insert just worked.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .